Topic on Project:Support desk

Jump to navigation Jump to search

Update Mediawiki 1.23.5 version to latest

4
Maddyyard (talkcontribs)

Hello there,

I would like to know is there a way to update my 1.23.5 of mediawiki to the latest stable version i.e 1.37? If so can you please help me.


Regards

Fokebox (talkcontribs)

And I would suggest to make update to LTS versions. 1.23.5 to 1.27 then to 1.31 then to 1.35.

As for 1.37 I tried to install it but I faced some php errors of this version.

Malyacko (talkcontribs)
Jonathan3 (talkcontribs)

Yes, that page says "Since Version 1.36, MediaWiki only commits to supporting upgrades from two LTS releases ago (see phab:T259771). Upgrades from older versions of MediaWiki will have to be performed in multiple steps. This means that if you want to upgrade to 1.36 from 1.23 or earlier, you'll first have to upgrade your 1.23 wiki to 1.27 (or 1.35), and, from 1.27 (or 1.35), you'll be able to upgrade to 1.36."

So you could either go from 1.23 --> 1.27 --> 1.37

or 1.23 --> 1.35 --> 1.37

Reply to "Update Mediawiki 1.23.5 version to latest"