Topic on Help talk:CirrusSearch

Jump to navigation Jump to search

Elasticsearch v7.13.1 in mediawiki 1.35.1

14
143.97.2.35 (talkcontribs)

Hi , i have installed elasticsearch version 7.13.1 , into my mediawiki app 1.35.1 and Php 7.4.15 . Elastic search is installed properly and running .

now i have added cirrus Search and Elastica extensions.

Currently i am getting search engine result as MW default Search engine . No changes into my search engine.

should i downgrade the elastic search version or it will work fine.???


Please suggest me ,

DCausse (WMF) (talkcontribs)

Hi,

If you don't see any errors it is perhaps because CirrusSearch is not yet activated, please follow the steps in the README files:

  • run the maintainance script to create and populate the indices UpdateSearchIndexConfig.php and ForceSearchIndex.php
  • activate CirrusSearch setting $wgSearchType = 'CirrusSearch';

If you see errors please share them so that we can better you.

ZPapierski (WMF) (talkcontribs)

Hi,


One more thing to add - Cirrussearch isn't compatible with Elasticsearch 7.* - I recommend 6.* version, I personally use 6.5.4.


Hope that helps.

DCausse (WMF) (talkcontribs)

Sorry (I misread your question) as ZPapierski pointed out CirrusSearch with MediaWiki 1.35 is not compatible with elasticsearch 7.13.1 please check the README file for information about compatible versions.

Pooja2425 (talkcontribs)

Thanks for your rely!!

I think Cirrus Search is not Starting, I am getting MW default search engine results.

MediaWiki 1.35.1
PHP 7.4.15 (apache2handler)
MySQL 8.0.25
Elasticsearch 6.5.4

Done these steps

php extensions/CirrusSearch/maintenance/UpdateSearchIndexConfig.php

php /extensions/CirrusSearch/maintenance/ForceSearchIndex.php --skipLinks --indexOnSkip

php /extensions/CirrusSearch/maintenance/ForceSearchIndex.php --skipParse


Now $wgSearchType = 'CirrusSearch';


Not getting further what to do , to start my search engine as elastic search engine.

Please suggest me.

DCausse (WMF) (talkcontribs)

If all the previous steps worked without error after setting $wgSearchType = 'CirrusSearch'; CirrusSearch should be active.

You can verify by searching on your wiki and adding &cirrusDumpQuery at the end of the search results URL, it should display a JSON document reprensenting the query that CirrusSearch is sending to elasticsearch. If not it means that $wgSearchType = 'CirrusSearch'; is not taken into account or that the CirrusSearch extension is not loaded properly (make sure that it is loaded using wfLoadExtension).

Pooja2425 (talkcontribs)

Thanks for repling !!

Yes i am getting Json document after adding &cirrusDumpQuery .

But getting this into freshly installed test wiki.

In my actual wiki application, when i was trying ,,

php extensions/CirrusSearch/maintenance/UpdateSearchIndexConfig.php

php /extensions/CirrusSearch/maintenance/ForceSearchIndex.php --skipLinks --indexOnSkip

php /extensions/CirrusSearch/maintenance/ForceSearchIndex.php --skipParse

Now $wgSearchType = 'CirrusSearch';


indexing namespaces...

PHP Fatal error:  Declaration of Elasticsearch\Endpoints\Indices\Exists::getParamWhitelist() must be compatible with Elasticsearch\Endpoints\AbstractEndpoint::getParamWhitelist(): array in /data/www/html/wiki135/extensions/Elastica/vendor/elasticsearch/elasticsearch/src/Elasticsearch/Endpoints/Indices/Exists.php on line 45


Since elastic search have installed, on root so test wiki working fine But my actual mediawiki application showing error.

pls suggest...

DCausse (WMF) (talkcontribs)
143.97.2.35 (talkcontribs)

Thanks for your help!!

Now this problem is resolved ,But Further when I have used these.

1)php extensions/CirrusSearch/maintenance/UpdateSearchIndexConfig.php

2)php extensions/CirrusSearch/maintenance/ForceSearchIndex.php --skipLinks --indexOnSkip

3) php extensions/CirrusSearch/maintenance/ForceSearchIndex.php --skipParse


then Indexed 10 pages ending at 66507 at 185/second


But when i try to search anything in my search engine its not giving any result.

Since i have used yet above 3 steps only. Should i have to use Bootstrapping large wikis methods???

DCausse (WMF) (talkcontribs)

Hi,

CirrusSearch relies on the MediaWiki JobQueue for processing its updates, please be sure it's setup properly and that no jobs are still in the queue: php maintenance/showJobs.php --group

If it's empty please check mediawiki logs and elasticsearch logs there might be error messages there. If it's not empty please see Manual:Job_queue.

169.149.213.185 (talkcontribs)

Thanks for reply,

Please suggest, what are the setting need to do with my DataBase.

Pls suggest!! Bcs not getting search result .

This post was hidden by Pooja2425 (history)
Pooja2425 (talkcontribs)

Hi Since i have Run jobs , Now they is no job in the queue.

PoolCounter and Bootstrapping large wikis methods are not tried yet.

Should i have to implement all also . Bcs ima not getting results form search engine

Pls suggest !!!

Reply to "Elasticsearch v7.13.1 in mediawiki 1.35.1"