Topic on Project:Support desk

Jump to navigation Jump to search

Version Upgrade from 1.30 to 1.34

15
Summary by TiltedCerebellum

User resolved

Satyaps2251 (talkcontribs)

Hi all,

regarding upgrade i have download 1.34...tar.gz file and extracted into /srv/www/mediawiki (where my old version location) and copied Localsettings.php into new version file.

its dont working..


plesae help me ..thanks a lot


Majavah (talkcontribs)

What do you mean by "it's not working"?

Satyaps2251 (talkcontribs)

Hi Majavah

Thank you for your reply

I mean website is not opening...


Thank you

Majavah (talkcontribs)

What exact message are you getting? Do you just have a blank screen? What version of PHP are you using? Did you run the updater script?

Satyaps2251 (talkcontribs)

Hi Majavah,

Its blank screen,nothing displaying..

I have PHP 7.2.24


Thank you

Majavah (talkcontribs)
TiltedCerebellum (talkcontribs)

Did you copy the new files over the old ones? If so, you’re not supposed to do that. Also you never answered if you ran update.php. Additionally on upgrade, you often can’t just use your old LocalSettings.php file as it was and expect the site to work. Rename the old one, generate a new one by browsing to <your site>/mw-update/. Upload that with no extensions enabled and check that the new version works clean. Also, did you update your extensions to versions matching your new mediawiki version? Make sure you have. If the site runs fine with no extensions enabled, start adding them (the extensions for MW 1.34) back one at a time. That way you’ll know if the issue is extension(s) related for example.


In The update from 1.33-1.34, after updating my extensions to the right version, I had problems with 2 extensions, I discovered that by starting with a newly generated localsettings.php and adding back a little bit at a time until I knew where the issue was.

Satyaps2251 (talkcontribs)

Hi,

  1. I haven't copied the new files over the old one
  2. i had ran php update.php script
  3. i copied Localsettings.php from old to new version folder
  4. link also changed to new version path
  5. trying to <my site>/mw-config/ is still aktuellisiert from old one
  6. and also trying with <my site>/mw-update/ getting 404 Not Found Error

thanks a lot for your kind reply

Majavah (talkcontribs)
Satyaps2251 (talkcontribs)

Hi,

I made changes as per above link instructions,still blank page..

actually i would like add extension (Lockdown) for my wiki (version 1.30),its not working.

so planned to upgrdae version 1.34,but it dont works

please let me know any possible other ways..

Thank you for ur kind reply

TiltedCerebellum (talkcontribs)

Your first problem is in #3 of your own steps, you copied everything from your old LocalSettings.php (or from your old file to the new one) to the new install and just expected it to work. That's not going to work (often this results in a problem, the exact problem you are describing). I had the same problem moving from MW 1.33 to 1.34.2.

  1. On the remote server (and in your local folder) rename your LocalSettings.php file to something else (to preserve it but move it out of the way so we can let MW regenerate a CLEAN one.
  2. Navigate to <yoursite>/mw-config/ (with your old one renamed on the server, this will now allow you to generate a new/CLEAN LocalSettings.php with NONE of your old settings in it (which is what we want). Fill in the required information, and let it download a CLEAN LocalSettings.php. leave it as it is, CLEANLY regenerated, don't add your old stuff back to it, don't copy over it or into it yet.
  3. Upload the CLEAN LocalSettings.php file that you just created to your site.
  4. Test if the site works using the CLEAN LocalSettings.php file (it should, don't worry about how the site looks/works yet. What we're testing first is IF your mediawiki installation is first valid and working and if the problem is in the contents your old localsettings file).
  • IF MediaWiki runs on a CLEAN LocalSettings.php then the problem is IN your old/existing LocalSettings.php file (one of the lines in it).
  • IF Mediawiki DOESN'T run on a CLEAN LocalSettings.php then the problem is in how you installed MediaWiki or the download files.
  1. If the site works after uploading the CLEAN LocalSettings.php, then the problem is IN your OLD LocalSettings.php file or one of the lines you copied from it. You need to copy and paste back, ONLY 1-3 lines at a time from old to CLEAN to figure out where your issue is. Every time you paste a few lines from old to CLEAN, upload the file, and retest if your site loads, until it starts giving the white page again (this will identify what the problematic lines are in your old LocalSettings.php file). It may be more than one line. So comment out the problematic ones, then keep going. Come back here and report what you found please. If you don't understand what we're saying to do, you probably need someone to help you with doing a clean install, clean LocalSettings.php regeneration, and carry over your settings one at a time (testing in between to identify which line in your old LocalSettings is causing the white pages):
  • See Professional development and consulting Also point them here. Your issue is quite likely, a line in your old LocalSettings.php causing the issue. So, using your old LocalSettings.php on the new site (or copying lines from it to the new one) and expecting it to work. Often it won't, it didn't for me. I had some lines and an extension (even though the extension was upgraded to a 1.34 version) in the old one causing the white page. Then I decided to start with a CLEAN LocalSettings.php regenerated using mw-config, test that the site worked with a clean one, it did (so now I knew my issue was a line (or lines) in my LocalSettings.php). Then I had to add back a few lines from old to new, test the site, add back a few more, test the site, and continue doing that until I found the offending lines and extensions (there was more than one) in the old LocalSettings that was causing the new one to blank the site, also short URL config will do it too (has to be re-setup and re-set in .htaccess to work).

Good Luck!

Satyaps2251 (talkcontribs)

Hi,

Thank you for your Kind reply,

  1. newly extracted Version dont have any Localsettings.php,if Im trying generate (<my-site>/mw-config/) is always asking about Upgarde Key from Localsettins.php (if add Upgrade key from Old one,simply getting message your Installation is over).
  2. (<my-site>/mw-config/) its always starts ,Installation from Old Version (not from new one)

Thank you

TiltedCerebellum (talkcontribs)

Your installation should look like this (an installation upgrade connecting it to an existing database) and offer a way to regenerate the LocalSettings.php if it doesn't try clicking the "Restart Installation" button at the right side.

https://imgur.com/uE7LmJ5

Satyaps2251 (talkcontribs)

Hi;

Thank you for your reply,

1.whichever Version i start to <mw-config> (without LocalSettings.php File) automatically its start from 1.30.0

2.and asking Upgrade key (if i dont enter key from old one, no forward option),after entering upgrade key from older Localsettings.php File getting message "your wiki is aktulliesiert and ready to use"

3. not generating any new Localsetting.php

4.I tried from "Restart Installation" Button also,repeating same


Thank you

Satyaps2251 (talkcontribs)

Thank you all..

it was small mistake on my approach..


Thanks a lot for kind responses..