Topic on Project:Support desk

Jump to navigation Jump to search

Page content missing after upgrading to 1.31

16
217.62.3.177 (talkcontribs)

I partly have this problem: Manual:Errors and symptoms#All pages have no content, but when editing a page the wiki text is there

The solution mentioned is upgrading to a supported mediawiki version but this occurred after the upgrade to 1.31

But its a bit vague because some parts can be seen on the page but the majority can not. The language bar, categories and a Infobox template are viewable but the rest of the page content is not. It is also not on all pages, just on some.

All googling just directs me to the error I mentioned earlier. Any help would be appreciated.

217.62.3.177 (talkcontribs)
Ciencia Al Poder (talkcontribs)

I don't know what could be the problem. parsing the page from the api gives the entire contents.

Maybe some of your extensions is misbehaving. Have you tried disabling WikiSEO? Also, try viewing the page with another skin

217.62.3.177 (talkcontribs)

If I disable WikiSEO content seems to appear agian but it makes me think the problem lies elsewhere as it now shows me a different similar problem.


If I disable WikiSEO the first section of the page seems re-appear but stops after a section from the Tabber extension. If I click on the last/most right Tabber tab it doesn't show the content in that tab but it does show the content that is supposed to be below the Tabber section. Disabling the Tabber extension shows all content immediately. But this makes me think something else is causing this because it are 2 extensions that are causing very similar problems while this all works perfectly on the production site with 1.28

217.62.3.177 (talkcontribs)

Disabling ParserFunctions with WikiSEO and Tabber on seems to show all content but as expected not as it should be. (Because pretty much all our templates use it). Updating ParserFunctions seem to have no effect

217.62.3.177 (talkcontribs)

Tried viewing the page with MonoBook, same result.

AhmadF.Cheema (talkcontribs)

Along with MediaWiki core, have you updated those extensions too?

217.62.3.177 (talkcontribs)

Yeah, everything was updated at the same time

Ciencia Al Poder (talkcontribs)

WikiSEO is adding some strange markup on the page, like p HTML tags inside HTML comments, which are inside other p tags. If your wiki or server has some sort of HTML tidy enabled, it may get confused by that and remove the content. MediaWiki already comes with an internal HTML sanitizer, which could be the culprit. See $wgTidyConfig (although it's not clear for me if this can be disabled).

About Tabber, in the api results I can see that the last tab is "Weaponry". Inside that element there are 2 HTML p elements with class mw-empty-elt, and then the h2 element of the Features section, but no closing div for that tab. Looks like there may be some unbalanced HTML on the VehicleWeaponry template, or a bug in the extension (which I doubt because it's a very simple one)

There may be 2 problems here. Try to isolate them. Create a page first without the WikiSEO stuff and only tabber, and try to locate the problem with tabber.

217.62.3.177 (talkcontribs)

Going to check this all but its weird because its using the same content as our site which is currently live on MW 1.27.2 (not 1.28) and on there it is working. The server is a copy of the live server. ( Available at https://starcitizen.tools ) The only thing that has changed is the MW Core and extension files

217.62.3.177 (talkcontribs)

I have set $wgTidyConfig = null; which seems to resolve the Tabber problem. But it doesnt fix WikiSEO, which is still causing the same problems.

Ciencia Al Poder (talkcontribs)

MediaWiki 1.27 was using no tidy at all (unless configured). But MediaWiki 1.31 uses RemexHTML. This change may cause some differences in parsing output. However, I think there may be some problem in one template causing Tabber to misbehave. WikiSEO problem may be caused by some change in how MediaWiki renders code now. I see WikiSEO is doing some funky things with HTML output that may be the cause of the problem.

217.62.3.177 (talkcontribs)

I can look into the template further later. We had no problems in 1.27 with Tidy disabled so I might just leave that disabled.

As for WikiSEO what do you recommend I do? Not sure what my options are

Ciencia Al Poder (talkcontribs)

Report the problem to the maintainer of the extension. MediaWiki 1.30 is a LTS, you can try upgrading to 1.30 instead of 1.31 and see if it works on that version, until a fix is available.

2001:16B8:107B:7E00:4084:8448:355:3311 (talkcontribs)

Actually, 1.31 is the LTS version. ;-)

Ciencia Al Poder (talkcontribs)

Oops, indeed sorry

Reply to "Page content missing after upgrading to 1.31"