Topic on Extension talk:PDFEmbed

Jump to navigation Jump to search

Blank Frame and no PDF displaying

5
Summary by RodolfoEBDR

There was an error with the $wgServer parameter. After hardcoding the URL of the server, it worked.

RodolfoEBDR (talkcontribs)

Hi! I'm using PDFEmbed 2.0.1, PdfHandler (21f2fe9) and MW 1.31. Wiki works fine but PDF Embedding isn't working. It displays a blank frame where is supposed to appears the PDF file. There's nothing rare with folder permissions. It isn't an user permission on editing the page (I'm trying as administrator).

Any ideas?

RodolfoEBDR (talkcontribs)

PS: the frame is outlined. It seems like the PDF is not being loadead o something, but no error is adviced. When inspecting the source code, the frame refers to "about:blank" in Firefox (and in Chrome it replicates the current page, like an frame embedding the page itself)

Here's how it looks like: https://imgur.com/dZjX8Fw

194.237.95.149 (talkcontribs)

I have the same issue. Chrome is telling me that the pdf file is being transfered thru HTTP while the rest of our site is using HTTPS and that this is considered unsure.

Not sure how to solve this.

"Mixed Content: The page at 'https://wiki-test.domain.net/index.php/test_24' was loaded over HTTPS, but requested an insecure resource 'http://wiki-test.domain.net/images/5/57/test.pdf#page=1'. This request has been blocked; the content must be served over HTTPS."

RodolfoEBDR (talkcontribs)

When inspecting debug mode in Firefox over the frame, it says:

Could not load the source for blob:https://192.168.0.154/f48cbb41-9ec6-467b-ac78-e683b4216b0e.

I don't know what is trying to parse the extension. Thumbnails are being generated correctly, so that means that the files in images/ can be located. Please help us!!! Hahaha

RodolfoEBDR (talkcontribs)

Here's the full debug message from Firefox:

Error cargando URI: Could not load the source for blob:https://192.168.0.154/f48cbb41-9ec6-467b-ac78-e683b4216b0e. [Exception... "Failed to open input source 'file:////192.168.0.154/f48cbb41-9ec6-467b-ac78-e683b4216b0e'" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://devtools/shared/base-loader.js -> resource://devtools/shared/DevToolsUtils.js :: mainThreadFetch :: line 645" data: yes] Stack: mainThreadFetch@resource://devtools/shared/base-loader.js -> resource://devtools/shared/DevToolsUtils.js:645:5 _getSourceText/<@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/source.js:410:27 Line: 645, column: 0