Habillage:Nostalgia

From mediawiki.org
This page is a translated version of the page Skin:Nostalgia and the translation is 100% complete.
Manuel des habillages MediaWiki - catégorie
Nostalgia
État de la version : stable
Politique de compatibilité Versions ponctuelles alignées avec MediaWiki. Le master n'est pas compatible arrière.
MediaWiki 1.22+
Licence Licence publique générale GNU v2.0 ou supérieur
Téléchargement
Exemple Nostalgia Wiki, Wikimedia Skins Lab
Téléchargements trimestriels 16 (Ranked 27th)
Utilisé par les wikis publics 5,434 (Ranked 5th)
Habillage par défaut des wikis publics 1
Traduisez l'habillage Nostalgia sur translatewiki.net
Problèmes : Tâches ouvertes · Signaler un bogue

Nostalgia est un habillage qui ressemble à l'interface de UseModWiki, le moteur qui propulsait Wikipedia à ses débuts (en 2001).

Il est actuellement utilisé sur le wiki nostalgia montrant l'apparence et le contenu de la Wikipedia fin 2001. Il faisait partie du noyau MediaWiki jusque MediaWiki 1.21 , puis a été supprimé en MediaWiki 1.22 (Gerrit #Ia6d73c) et il est maintenant disponible pour la postérité, comme habillage séparé .

Si vous souhaitez l'utiliser avec MediaWiki 1.22 ou 1.23, utilisez (respectivement) les branches REL1_22 ou REL1_23, car le master de Git n'est compatible qu'avec le master de MediaWiki.

Installation

  • Téléchargez et placez le(s) fichier(s) dans un répertoire appelé Nostalgia dans votre dossier skins/.
  • Ajoutez le code suivant à la fin de votre fichier LocalSettings.php  :
    wfLoadSkin( 'Nostalgia' );
    
  • Yes Fait - Naviguer vers Special:Version sur votre wiki pour vérifier l'installation correcte de l'habillage.

Pour les utilisateurs exécutant MediaWiki 1.24 ou une version précédente :

Les instructions ci-dessus expliquent la nouvelle façon d'installer les habillages en utilisant wfLoadSkin(), depuis MediaWiki 1.25. Si vous avez besoin d'installer cet habillage dans une version précédente, à la place de wfLoadSkin( 'Nostalgia' );, vous devrez utiliser :

require_once "$IP/skins/Nostalgia/Nostalgia.php";

(Pour qu'un habillage soit opérationnel sur une ancienne version, il peut se révéler nécessaire de télécharger la version correspondant à votre version de MediaWiki sur Special:SkinDistributor.)