Jump to: navigation, search
Parsoid's support for specific Node.js versions will be dropped around the same time that the specific Node.js version reaches its EOL.[1][2]

0.8.0 (released Oct 27, 2017)[edit]

See src/ for details of what changed in Parsoid since the previous release

Notable changes:

  • Audio/video support
  • Red links and disambiguation links marked up
  • Support for improved TemplateData format specifier which lets templates control formatting of transclusions after VE edits

0.7.1 (released Apr 5, 2017)[edit]

The v0.7.0 release falsely claimed that nodejs v0.10 was still supported and didn't update the debian control file to update the nodejs dependency. This release fixes the dependency to require nodejs >= 4.0.0. This prevents users installing Parsoid v0.7.1 without upgrading nodejs to a >= v4.0.0 version.

0.7.0 (released Apr 4, 2017)[edit]

This is the last release with support for node 0.10. node v4 at minimum is now required. Wikimedia production version is using node v6.

The only notable change in this release is a native Parsoid implementation of the <gallery> extension. Besides that, there have been a number of bug fixes.

See src/ for details of what changed since the 0.6.1 release.

0.6.1 (released Nov 14, 2016)[edit]

0.6.1 is a release to replace the broken 0.6.0 debian package. Here are the major highlights since the 0.5.3 release.

There are two big changes in this package that might potentially be breaking changes for some installations.

  1. In this upgrade, Parsoid has migrated to the service-runner npm package for providing the scaffolding for Parsoid's server.
    • service-runner expects a config.yaml file instead of a settings.js file. Parsoid's config.yaml file lets you use a settings.js file via the localsettings config option there.
    • This debian package automatically updates the config.yaml file to point to any pre-existing /etc/mediawiki/parsoid/settings.js file which should let you upgrade your Parsoid package without breaking your install.
  2. The other big change is the removal of the previously deprecated v1/v2 APIs in Parsoid. This shouldn't affect you unless you have scripts that reference those APIs. Your VisualEditor installation *might* break if you haven't updated it recently if it were using these older APIs. If you installed or upgraded your VisualEditor installation in 2016, you are unlikely to be affected.

See src/ in the repository for more specific details of what changed in Parsoid since the 0.5.3 release.

0.5.3 (released Nov 1, 2016)[edit]

This is a security fix release of Parsoid and patches v0.5.1 with a fix for a reflected XSS security hole in the Parsoid API.

0.5.1 (released Jun 3, 2016)[edit]

This is the latest release of Parsoid and corresponds to v0.5.1 in the Parsoid repo. and v0.5.1 in the deploy repo. This version of Parsoid is compatible with the latest release of MediaWiki (1.27.0) and the related latest branch of VisualEditor, REL1_27. The debian package for it can be found here and installed via apt-get on debian systems.

Changes since 0.4.1
  • Add v3 API to match RESTBase's API URL formats
  • Lots of code cleanup + removal of dead code
  • Parsoid code repository reorganized
  • Keep data-* attributes at the edge of DOM
  • Various performance fixes to handle pathological scenarios
  • Added initial support for a Parsoid-native extension registration mechanism (undocumented and breaking changes expected till this is finalized)
  • Added initial support for an autoload mechanism for extensions
  • Lots of bug fixes

Note: v0.5.0 was a bad debian package and has been subsumed by v0.5.1.

0.4.1 (released Sep 17, 2015)[edit]

This is the previous released version of Parsoid and the debian package is no longer available in the mediawiki releases repository. Please upgrade to v0.5.1

0.4.0 (released Sep 2, 2015)[edit]

This version, while still available in the mediawiki releases repository, is slated to be removed shortly. Please upgrade to v0.5.1.

0.3.0 (released Jun 25, 2015)[edit]

0.2.0 (released Dec 2, 2014)[edit]