MediaWiki 1.21/wmf9

Jump to: navigation, search

Other languages:
dansk • ‎English • ‎føroyskt • ‎français • ‎עברית • ‎italiano • ‎日本語 • ‎Lëtzebuergesch • ‎polski • ‎українська
TriangleArrow-Left.svgMediaWiki 1.21/wmf8 Deployment of MediaWiki 1.21wmf9 to Wikimedia sites MediaWiki 1.21/wmf10TriangleArrow-Right.svg

The latest version (labeled "1.21wmf9") of MediaWiki, the software that powers Wikipedia and its sister sites, is being deployed to all Wikimedia sites in stages, starting on Monday, 4 February 2013 (see the roadmap).

We will continue to deploy the latest software every two weeks. This is intended to minimize disruption and possible issues, and make it easier to identify the cause of problems, since the possibly problematic code will be much more recent.

Most important changes[edit | edit source]

Breaking changes[edit | edit source]

Core changes[edit | edit source]

Extensions[edit | edit source]

AbuseFilter[edit | edit source]

ApiSandbox[edit | edit source]

ArticleFeedback[edit | edit source]

ArticleFeedbackv5[edit | edit source]

Babel[edit | edit source]

CategoryTree[edit | edit source]

CentralAuth[edit | edit source]

CentralNotice[edit | edit source]

Cite[edit | edit source]

  • git #d91d8a8 - Adapt the <gallery> parser test for $wgResponsiveImages

CodeEditor[edit | edit source]

  • git #8ee1900 - Disable background linting using WebWorkers

DataValues[edit | edit source]

Diff[edit | edit source]

DonationInterface[edit | edit source]

  • git #b860cb4 - Shunting the final status log line off to a gateway-indifferent syslog bucket of its very own, so we can tail everything at once.
  • git #a4ac3dc - Logging Cleanup: Searched for log lines that deserved to be qualified as LOG_ERR or something more severe, and added what I feel is a vaguely appropriate log level. Added a setting that will, when unset, suppress the avalanche of LOG_DEBUG level statements that we usually don't want. Also some documentation. Gasp.
  • git #3eef71e - Let's make Amazon work with the form chooser
  • git #2116243 - Making GatewayFormChooser work
  • git #f9c076c - (FR #595) Adyen payment gateway
  • git #04ab3f1 - Readding Exception Details
  • git #e2e9b05 - Abstract out redirect method

E3Experiments[edit | edit source]

  • git #4e9af22 - Revert "Update logging for end of split test."
  • git #0912c58 - Update logging for end of split test.
  • git #78c8cec - Bump schema and change GettingStarted experimentId to ob3-split.

Echo[edit | edit source]

  • git #6347618 - Fixing notification type to be 'web' in controller
  • git #a05cb46 - Excludes user-dismissed events from count
  • git #16331ea - Adding dismiss functionality to flyout overlay.
  • git #24eadab - (bug 44814) Don't double-escape the date header on Special:Notifications
  • git #b21e503 - Update comment and db selection
  • git #fdf1bc6 - Some consistency tweaks for I484a24b424e69be3640e63b76f82735edae6f13a
  • git #af06e26 - Adding dismiss functionality to special page
  • git #d0ddc2a - Fixing unread state for flyout - CSS tweak
  • git #78ad57d - Abstracting MySQL in Echo so storage type can be swapped easily
  • git #d09640c - Add special page to the "users" section on Special:SpecialPages
  • git #eefab40 - Allow events to specify that they should notify the agent.
  • git #d541e7b - Using human-friendly relative timestamps rather than absolute timestamps
  • git #da0a52b - Update 'cross referenced' to 'linked' for consistency
  • git #dadd7b0 - Putting all the default user options together in the config

EducationProgram[edit | edit source]

EventLogging[edit | edit source]

FeaturedFeeds[edit | edit source]

  • git #feed1ac - Rename calls to wfArrayToCGI to wfArrayToCgi

FlaggedRevs[edit | edit source]

GeoData[edit | edit source]

GettingStarted[edit | edit source]

  • git #b712963 - Revert "Remove implementation of split test:"
  • git #0202d67 - Remove implementation of split test:
  • git #7601e0f - Don't send users on GuidedTour when they loaded Special:GettingStarted manually (isNew false).
  • git #69298a7 - Put link description back.

GuidedTour[edit | edit source]

LiquidThreads[edit | edit source]

Listings[edit | edit source]

MWSearch[edit | edit source]

  • git #2c3c99c - Rename calls to wfArrayToCGI to wfArrayToCgi

Math[edit | edit source]

MobileFrontend[edit | edit source]

OAI[edit | edit source]

  • git #04ad2dc - Rename calls to wfArrayToCGI to wfArrayToCgi

OpenStackManager[edit | edit source]

PageTriage[edit | edit source]

ProofreadPage[edit | edit source]

Renameuser[edit | edit source]

  • git #967e55b - Add flag to RenameuserSQL to skip username check

Scribunto[edit | edit source]

SecurePoll[edit | edit source]

SyntaxHighlight_GeSHi[edit | edit source]

TimedMediaHandler[edit | edit source]

TorBlock[edit | edit source]

  • git #b9326f2 - More annoying debugging
  • git #939a522 - Comment out annoying useless log entries
  • git #401f5e7 - Swap wfDebug() for wfDebugLog() so output can be grouped
  • git #acb9650 - Added SSL verification when retrieving node list.
  • git #7eade79 - Added Onionoo list loader and reorganized functions.
  • git #4e2b3f0 - Sanitized coding style and improved documentation.
  • git #878bc6d - Put loadExitNodes.php into a Maintenance class.

Translate[edit | edit source]

TranslationNotifications[edit | edit source]

UniversalLanguageSelector[edit | edit source]

UploadWizard[edit | edit source]

UserMerge[edit | edit source]

VisualEditor[edit | edit source]

WikiEditor[edit | edit source]

WikiLove[edit | edit source]

Wikibase[edit | edit source]

WikimediaMaintenance[edit | edit source]

  • git #7c791a5 - Make getJobQueueLengths only count jobs with no token
  • git #f1f6fb1 - Fix paths back to /h/w/c based
  • git #4b664bd - Remove /dblist from path (no git deploy yet)
  • git #833de43 - Change script for creating translate tables to more generic

WikimediaMessages[edit | edit source]

  • git #33bb09b - Followup I6cddbdc6: Use protocol relative for
  • git #19fa5c8 - Add Wikidata license terms

cldr[edit | edit source]

timeline[edit | edit source]

  • git #0c20cc0 - fixes for
  • git #cad349a - consistently use <div class="error"> for user-visible errors