Manual:Pywikibot/Compatibility

From MediaWiki.org
Jump to navigation Jump to search
Other languages:
English • ‎Nederlands • ‎français • ‎čeština • ‎日本語

This page summarizes Pywikibot compatibility with Python and MediaWiki. Python 2.7.4 or higher, or Python 3.4 or higher is currently required to run the bot, but Python 3.5 or higher is recommended.

Branches, releases – Python and MediaWiki deprecation graph[edit]

Legend[edit]

Horizontal
orange: implementation/deprecation period
dark gray: supported
Vertical
gray: Pywikibot releases
blue: git tags
red: current master


Branches – Python support table[edit]

Python version Pywikibot 3 branch
masterstablepython2
Comment Current branch for developing and testing. Use it on your own risks but any bug reports are welcomed. Stable branch for production systems; updated monthly after passing unit tests. Stable branch for production systems running in Python 2 environment; no longer updated.
<= 2.7.3 no support
2.7.4 – 2.7.18 no support deprecated OK
3.0 – 3.3 no support
3.4 no support deprecated OK
3.5 – 3.8.4*) OK
3.9 on probation no support
3.10 no support

Releases – Python and MediaWiki support table[edit]

Pywikibot Release date Python MediaWiki
3.0.20190722 22 July 2019 2.7, 3.4–3.7 1.14–1.34
3.0.20200111 11 January 2020 2.7, 3.4*)–3.8 1.14–1.35
3.0.20200508 8 May 2020 2.7, 3.4*)–3.8 1.14–1.35
3.0.20200609 9 June 2020 2.7, 3.4*)–3.8 1.14–1.35
3.0.20200703

stable
python2

3 July 2020 2.7, 3.4*)–3.8 1.14–1.35
4.0 x August 2020 3.5–3.8 1.19–1.35

*) Already desupported and not tested.