Manual:Installation Médiawiki chez free.fr

From MediaWiki.org
Jump to navigation Jump to search

Généralité[edit]

  • Le FAI Free.fr propose des pages perso gratuites permettant de créer son propre site web. Apache, PHP, MySQL sont disponibles ce qui, à priori, permet d'installer mediawiki.
  • Cependant Free impose des limitations de php notamment qui peuvent poser des problèmes
  • Ces problèmes varient avec le temps :
    • évolutions des versions de Mediawiki
    • évolutions des versions de php disponibles sur les serveurs Free
    • évolutions des limitations imposées par Free

Point le 10 juillet 2016[edit]

Affichage des images : les images, une fois "uploadées", ne s'affichent pas. Seuls leurs noms, sous forme de liens. Une solution ?

Point au 19 octobre 2015[edit]

  • L'hébergeur Free.fr met actuellement à disposition PHP 5.6.8 et MySQL 5.0.83

Il est donc tout à fait possible d'installer la dernière version de médiawiki (aujourd'hui la 1.25.3), mais il y a quelques opérations à faire avant.

  1. Bien sûr, dans le fichier .htaccess à la racine de son espace perso (xxx.free.fr), mettre la ligne : php56 1
  2. Il semble nécessaire de créer un dossier nommé "sessions" à la racine de l'espace personnel (xxx.free.fr)
  3. Uploader par ftp (ftpperso.free.fr) mediawiki. Disons que j'ai tout installé dans le répertoire /mediawiki
  4. Pour permettre le Setup (bug ?), il faut aller modifier le fichier /mediawiki/includes/db/Database.php :
    1. Remplacer la ligne : 'mysql' => array( 'mysqli', 'mysql' ),
    2. Par 'mysql' => array( 'mysql' ),
    3. Enregister la modification !
  5. Et là, normalement, en mettant dans votre navigateur xxx.free.fr/mediawiki, vous arrivez sur le setup qui doit se dérouler sans encombre.
    1. Après avoir Uploader le fichier LocalSettings.php nouvellement téléchargé dans le répertoire mediawiki,
    2. Tester son site : xxx.free.fr/mediawiki
    3. A ce stade, il vous est possible (mais pas obligatoire !) de remettre le fichier /mediawiki/includes/db/Database.php dans son état d'origine (cf point 4)
  6. Puis vous allez constater que l'import de fichier sur votre mediawiki ne marche pas (erreur: "Could not acquire lock for ...". C'est normal, free.fr a bloqué la fonction php : flock()(voir http://www.free.fr/assistance/943.html)
    1. La solution consiste à modifier le fichier : /mediawiki/includes/GlobalFunctions.php
    2. Rajouter ceci à la fin du fichier :

/**
* Pour remplacer la fonction flock() bloquée sur www.free.fr
* TODO : Remplacer dans Mediawiki :
* flock par newFlock
*/
function newFlock($a,$b) { return true; }


Puis dans les 3 fichiers suivants, remplacer flock par newFlock :

  • /mediawiki/includes/filebackend/lockmanager/FSLockManager.php
  • /mediawiki/includes/utils/UIDGenerator.php
  • /mediawiki/includes/jobqueue/JobRunner.php


Tester à nouveau ...


Remarques :

  • La proposition décrite dans l'article Manual:Disabling_file_lock_manager corrige le problème d'import (FSLockManager) mais n'apporte pas de solution aux 2 autres fichiers (UIDGenerator & JobRunner).
  • Attention après chaque mises à jour de Mediawiki, il faudra mettre à jour les 4 fichiers.
  • Le fait que free.fr limite les droits fichiers à 700 et 755 au maximum, n'est pas un problème.
  • Pour l'utilisation du skin Bouquet, j'ai dû supprimer /mediawiki/images/.htaccess pour affichier l'image du header.

Point au 24 octobre 2012[edit]


  • La dernière version disponible de mediawiki est la 1.19 qui necessite au minimum la version PHP 5.3.0
  • L'installation automatique de mediawiki sur une page perso Free conduit donc à l'erreur suivante :
    • MediaWiki 1.19 internal error
    • MediaWiki 1.19 requires at least PHP version 5.2.3, you are using PHP 5.1.3RC4-dev.
    • please consider upgrading your copy of PHP. PHP versions less than 5.3.0 are no longer supported by the PHP Group and will not receive security or bugfix updates.
    • If for some reason you are unable to upgrade your PHP version, you will need to download an older version of MediaWiki from our website. See our compatibility page for details of which versions are compatible with prior versions of PHP.
  • Il n'est donc pas possible pour un non expert d'installer mediawiki 1.19 chez free.fr

Solutions de contournement[edit]

Installation de la version 1.16.5[edit]

le 14 février 2013 il a été possible d'installer la version 1.16.5 de mediawiki mediawiki-1.16.5.tar.gz avec la version faite pour la 1.19 de ConfirmEdit (attention, si vous laissez votre wiki en libre accès, vous aurez de bonnes chances de vous faire spammer et Free ne tardera pas, après que votre base SQL aura explosé, à fermer votre page perso définitivement comme cela m'est arrivé il y a peu de temps). Bien sûr, n'oubliez pas d'ajouter un fichier .htaccess dans la racine de votre wiki ou de votre site free.fr, le mien contient deux lignes :

PHP 5 options -indexes

J'ai également (réussi) à ajouter l'extension SyntaxHighlight_GeSHi. J'ai dû mélanger deux versions de l'extension pour qu'elle fonctionne avec mediawiki 1.16.5. Voici l'archive que j'ai faite avec les sources : SyntaxHighlight_GeSHi pour mediawiki 1.16.5

Bonne Chance !