Extension talk:Wiki Administration Tool

Jump to navigation Jump to search

About this board

AABoyles (talkcontribs)

Hey! This looks like a fantastic piece of software. I'm trying to get it running on a Mediawiki running on PostGres, and as I'm configuring it I notice that the instructions describe support for MySQL, and don't say anything about other DBs. I'm having a lot of trouble getting it up and running, and I'm wondering if that's the reason, or should it run on Postgres (i.e. the problem is something else)?

Kghbln (talkcontribs)

I also failed on this in the past, too but for other reasons. I do not think that it supports PostgreS since it also catered for SMW which actually requires MySQL. You have to make sure that your wiki is on MW 1.17, too. I think this extension is currently? unmaintained. I am afraid that I cannot be of better help.

AABoyles (talkcontribs)

Only the latest version (1.8) of SMW requires MySQL--a version that was released since the last release of the Wiki Admin Tool. (I'm running SMW on Postgres right now, actually). But I didn't notice that it only works on MW 1.17. That's a bummer. Anyway, Thanks a lot, kgh! You're awesome.

Kghbln (talkcontribs)

Ah, you are the first one of whom I know that he is working with ProsgreS on SMW. Good to read that this works out for you. The SMW+ extensions were always heavily tied to a specific version, even maintenance version of MW since patches to core had to be done. I will now update the extension's page to make this dependency more clear. Cheers

Reply to "Works on Postgres?"
Hypergrove (talkcontribs)
Reply to "locations of repositories"
There are no older topics