Extension talk:Jsoner

Jump to navigation Jump to search

About this board

Any chance this will be updated for PHP7.1+?

1
Damenleeturks (talkcontribs)

I've tried installing this extension (MW 1.30.0, PHP 7.2.1) with composer and this is what I get.

> composer update
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.
 Problem 1
   - noris/jsoner 1.1.7 requires ext-intl * -> the requested PHP extension intl is missing from your system.
   - noris/jsoner 1.1.6 requires ext-intl * -> the requested PHP extension intl is missing from your system.
   - noris/jsoner 1.1.5 requires ext-intl * -> the requested PHP extension intl is missing from your system.
   - noris/jsoner 1.1.2 requires ext-intl * -> the requested PHP extension intl is missing from your system.
   - noris/jsoner 1.1.1 requires ext-intl * -> the requested PHP extension intl is missing from your system.
   - noris/jsoner 1.1.0 requires ext-intl * -> the requested PHP extension intl is missing from your system.
   - Installation request for noris/jsoner ~1.0 -> satisfiable by noris/jsoner[1.1.0, 1.1.1, 1.1.2, 1.1.5, 1.1.6, 1.1.7].

I did install php71-intl (in lieu of the intl prerequisite) after getting this error the first time, but it spat out the same thing after, too. Short of editing and updating the extension for myself, I'm at a loss.

Help, @JonasGroger

Reply to "Any chance this will be updated for PHP7.1+?"
There are no older topics