Extension:VectorBeta

From MediaWiki.org
Jump to: navigation, search
MediaWiki extensions manualManual:Extensions
Crystal Clear action run.png
VectorBeta

Release status:Extension status unmaintained

ImplementationTemplate:Extension#type MyWiki, Beta Feature
DescriptionTemplate:Extension#description Registers Beta Features that change the appearance of the Vector skin
Author(s)Template:Extension#username Jon Robson (jdlrobsontalk)
MediaWikiTemplate:Extension#mediawiki 1.22+
PHPTemplate:Extension#php 5.3+
Database changesTemplate:Extension#needs-updatephp No
LicenseTemplate:Extension#license GNU General Public License 2.0 or later
Download
Hooks usedTemplate:Extension#hook
GetBetaFeaturePreferences
SkinVectorStyleModules

Translate the VectorBeta extension if it is available at translatewiki.net

Check usage and version matrix.

Issues:

Open tasks · Report a bug

The VectorBeta extension adds alterations to the Vector skin to the list of beta features ahead of the features being merged into the core Vector skin for all MediaWiki users.

Available Beta Features
  • Typography experiment – Changes typography and other styling of content (initial parts merged).
    • Set via $wgVectorBetaTypography = true;
  • Compact personal tools – Merges the personal tools into a single drop-down menu
    • Set via $wgVectorBetaPersonalBar = true;
    • Requires event logging capabilities via Extension:EventLogging or similar.
  • Fixed header – Replace the static header with a dynamic header fixed to the top of the window, not page.
    • Set via $wgVectorBetaWinter = true;
  • Form Refresh
    • ...?...
  • Probably others.

Installation[edit]

  • Download and place the file(s) in a directory called VectorBeta in your extensions/ folder.
  • Add the following code at the bottom of your LocalSettings.php:
wfLoadExtension( 'VectorBeta' );
  • YesY Done - Navigate to Special:Version on your wiki to verify that the extension is successfully installed.

To users running MediaWiki 1.24 or earlier:

The instructions above describe the new way of installing extensions using wfLoadExtension(), since MediaWiki 1.25. If you need to install this extension in earlier versions, instead of wfLoadExtension( 'VectorBeta' );, you need to use:

require_once "$IP/extensions/VectorBeta/VectorBeta.php";