Topic on Project:Support desk

Jump to navigation Jump to search

Notice: Undefined index: createaccount in C:\wamp\www\wiki\includes\installer\LocalSettingsGenerator.php on line 225

24
GnuDoyng (talkcontribs)

Hello,

I installed MediaWiki 1.23.0 on a Windows 2003 Server and get the error notice of "Undefined index: createaccount in C:\wamp\www\wiki\includes\installer\LocalSettingsGenerator.php on line 225". The whole message goes like this:

Notice: Undefined index: createaccount in C:\wamp\www\wiki\includes\installer\LocalSettingsGenerator.php on line 225
Call Stack
# Time Memory Function Location
1 0.0000 149248 {main}( ) ..\index.php:0
2 0.0781 4810872 wfInstallerMain( ) ..\index.php:31
3 0.2344 8796128 WebInstaller->execute( ) ..\index.php:63
4 0.2656 9021832 LocalSettingsGenerator->getText( ) ..\WebInstaller.php:178
5 0.2656 9021880 LocalSettingsGenerator->getDefaultText( ) ..\LocalSettingsGenerator.php:137

I've done googling and tried various ways like adding lines of "error_reporting = E_ALL & ~E_NOTICE" and "display_errors = Off" in php.ini but none of them worked whatsoever. My system meets the minimum requirements perfectly: PHP 5.4.16 and MySQL 5.6.12. So I really don't see why this error always pops up, which is so frustrating. Is that a MediaWiki bug and is there a way to fix it? Can someone shed a light, please? Thanks!

MarkAHershberger (talkcontribs)

It looks like you've discovered a reportable bug. But the notice message looks like it is coming from XDebug, not php itself -- at least that is the error formatting I've seen before from XDebug.

The configuration documentation for XDebug seems to suggest that you try putting

 xdebug.scream = 0
 xdebug.force_display_errors = 0

in your php.ini or xdebug.ini file.

GnuDoyng (talkcontribs)

Tried that, and unfortunately, it didn't do the trick, either. That's just so weird and so frustrating...

I installed MediaWiki 1.23.0 on a Linux server and got the same error. So I presume there must be something wrong with the latest version.

Thanks for your help, anyway. Will you report the bug to the developing team?

Florianschmidtwelzow (talkcontribs)

> So I presume there must be something wrong with the latest version. No :) Installed it locally to test -> no errors ;)

One question: Have you anything changed at the mediawiki files? The readon for my question: Your backtrace says: 2 0.0781 4810872 wfInstallerMain( ) ..\index.php:31 wfInstallerMain() isn't called everywhere outside mw-config, but in mw-config/index.php (not index.php in mediawiki root).

From where you downloaded MediaWiki? Can you download again from official source and copy all files (overwrite the old ones) and test again?

Thanks!

GnuDoyng (talkcontribs)

Hi, I did download it from the official website and never changed anything in it. Now reverted to 1.22.7 (also downloaded from the official website) and the error was gone.

Florianschmidtwelzow (talkcontribs)

Can you try again to install 1.23? Like i said, i did it one hour before and it worked well :)

Brandon CS Sanders (talkcontribs)

I'm getting the same error with 1.23 fresh install. If I upgrade an existing mediawiki to 1.23 I don't get the error.

Brandon CS Sanders (talkcontribs)

It's cropping up for me because the installer dumped the error message at the top of the downloaded LocalSettings.php file. Deleting the spurious output at the top of LocalSettings.php cleared up the problem.

Ciencia Al Poder (talkcontribs)

The problem is that MediaWiki, when generates the LocalSettings.php file, it's including that error on the generated file!

MarkAHershberger (talkcontribs)

I don't understand how you're getting this message if you already have a LocalSettings.php file installed.

78.206.72.23 (talkcontribs)

I have exactly the same problem

Notice: Undefined index: createaccount in C:\wamp\www\mediawiki-1.23.0\includes\installer\LocalSettingsGenerator.php on line 225
Call Stack
#	Time	Memory	Function	Location

1	0.0005	383688	{main}( )	..\index.php:0
2	0.1012	9316264	wfInstallerMain( )	..\index.php:31
3	0.2779	16790888	WebInstaller->execute( )	..\index.php:63
4	0.3220	17245216	LocalSettingsGenerator->getText( )	..\WebInstaller.php:178
5	0.3220	17245216	LocalSettingsGenerator->getDefaultText( )	..\LocalSettingsGenerator.php:137

I perform a fresh install on a Local machine PC with vista and a wamp server 2.1

  • appache 2.2.17
  • PHP 5.3.5
  • mySql 5.5.8

I downloaded the mediawiki 1.23 from here https://tools.wmflabs.org/snapshots/#!/mediawiki-core/REL1_23

and the end of my localSetting.php is as :

# The following permissions were set based on your choice in the installer
$wgGroupPermissions['*']['edit'] = false;


# Enabled Extensions. Most extensions are enabled by including the base extension file here
# but check specific extension documentation for more details
# The following extensions were automatically enabled:
require_once "$IP/extensions/Cite/Cite.php";
require_once "$IP/extensions/ConfirmEdit/ConfirmEdit.php";
require_once "$IP/extensions/Gadgets/Gadgets.php";
require_once "$IP/extensions/Nuke/Nuke.php";
require_once "$IP/extensions/ParserFunctions/ParserFunctions.php";
require_once "$IP/extensions/PdfHandler/PdfHandler.php";
require_once "$IP/extensions/SyntaxHighlight_GeSHi/SyntaxHighlight_GeSHi.php";
require_once "$IP/extensions/WikiEditor/WikiEditor.php";
Florianschmidtwelzow (talkcontribs)

Hi, can you check, what is written at the top of localsettings.php? :)

78.206.72.23 (talkcontribs)

here is the begin of the localSettings.php

( ! ) Notice: Undefined index: createaccount in C:\wamp2\www\mediawiki-1.23.0\includes\installer\LocalSettingsGenerator.php on line 225
Call Stack
#TimeMemoryFunctionLocation
10.0004380376{main}( )..\index.php:0
20.10319312480wfInstallerMain( )..\index.php:31
30.289516786872WebInstaller->execute( )..\index.php:63
40.301017241072LocalSettingsGenerator->getText( )..\WebInstaller.php:178
50.301017241072LocalSettingsGenerator->getDefaultText( )..\LocalSettingsGenerator.php:137
78.206.72.23 (talkcontribs)

could you remove my following message, sorry it destroy the form message that i want send to you to answer to your request : (when i have make a copy of the beginning of LocalSettings.php générated and past it into the message)

In fact it is the generated localSettings.php which creates this bad chart !

78.206.72.23 (talkcontribs)

OK

after removing all the html code which is includes a the beginning of the localSettings.php : all is correct

it is strange this html code generation... I dont have this probleme when i install the same version 1.23 into a window 8.1 64bits

I have it only with my window vista 32bits

Florianschmidtwelzow (talkcontribs)

Hope that GnuDoyng read here :)

Can you both, GnuDoyng and 78.206.72.23, give us information about your system, such OS, PHP version, webserver version, maybe installed via wamp or xampp or something else? Normally there wouldn't write anything else as the configuration parameters to localsettings.php, so i think it's a problem of such version or installation method. I would try to reproduce but need more information :)

78.206.72.23 (talkcontribs)

system Window vista 32 bits Service Pack2

in the special page version of mediawiki : I see

MediaWiki 1.23.0

PHP 5.3.5 (apache2handler)

MySQL 5.5.8-log

and I have

wamp server 2.1

appache 2.2.17

Florianschmidtwelzow (talkcontribs)

Hello again! I have tested it with wamp 2.1 with apache 2.2.17 and php5.3.5, unhappily windows vista is the only windows OS higher than XP i haven't here, so i tested under Windows 7 32 bit :/

I had no error in installation process and no overhead in localsettings.php, sorry :(

85.138.195.141 (talkcontribs)

Hi,

Same problem here with a different message that was included in the header of the LocalSettings.php file.


Notice: Undefined index: read in M:\xampp\htdocs\sword.wiki\includes\installer\LocalSettingsGenerator.php on line 226


After removing these lines from the header of the LocalSettings.php the errors were gone.

This was a bit frustrating since I lost a couple of hours to get here and this html error was added to the LocalSettings.php during the installation process.

Something strange here... Buga!

Florianschmidtwelzow (talkcontribs)

It would helpful, when you say, what versions you use :D Like Windows-version, apache and php :) Thanks!

85.138.195.141 (talkcontribs)

Sure.

 Win 7-x64 and XAMPP 1.8.3:
 + Apache 2.4.4
 + MySQL 5.5.32
 + PHP 5.5.9 + PEAR
AJGeelle1 (talkcontribs)

Can you resolve these problems

{main}( )    ...\index.php:0

JApplicationCms->execute( )    ...\index.php:47

JApplicationAdministrator->doExecute( )    ...\cms.php:252

JApplicationAdministrator->dispatch( )    ...\administrator.php:152

JComponentHelper::renderComponent( )    ...\administrator.php:98

JComponentHelper::executeComponent( )    ...\helper.php:372

require_once( 'C:\wamp64\www\GDeero\administrator\components\com_config\config.php' )    ...\helper.php:392

ConfigControllerDisplay->execute( )    ...\config.php:31

ConfigViewComponentHtml->render( )    ...\display.php:104

JViewHtml->render( )    ...\html.php:77

include( 'C:\wamp64\www\GDeero\administrator\components\com_config\view\component\tmpl\default.php' )    ...\html.php:148

JFormField->__get( )    ...\html.php:83

JFormFieldListswitcher->getInput( )    ...\field.php:393

Ciencia Al Poder (talkcontribs)

Sorry but your problem doesn't seem to be related to MediaWiki, none of the files that appear on the error stack trace are from MediaWiki.

MarkAHershberger (talkcontribs)