Topic on Project:Support desk

Jump to navigation Jump to search

[RESOLVED] Mobilefrontend and google-analytics

7
TimMacG (talkcontribs)

Mediawiki:1.22.0 PHP:5.3.10-1ubuntu3.11 (apache2handler) MySQL:5.6.13-log

Hi,

I have this problem after installing MobileFrontend, that my sites mobile visitors dropped dramatically. Have others have this same problem and is there any fix for this? thanks

Florianschmidtwelzow (talkcontribs)

Hello!

Which version of MobileFrontend do you have? In an older version of MF, the hook used for the Google Analytics extension wasn't loaded in MobileFrontend. But this should be fixed in the actual version. REL1_22 of MobileFrontend doesn't have the fix, iirc. Can you update your MediaWiki (and MobileFrontend) version?

TimMacG (talkcontribs)

Thank you for the reply. I´m not sure. :/ On my special:version page it doesnt say wich version of MF i have? Where could I see it? Would you suggest to update the whole mediawiki? I would do that but I am a bit afraid it would cause some problems with other extensions. Is there away to maybe add that missing line of code to mobilefrontend or google-analytic?

Florianschmidtwelzow (talkcontribs)

MobileFrontend doesn't have a version number, that's right, so you have to know, which version you downloaded in order to know, which version you have :)

Nevertheless, i think you have REL1_22, which is the latest version working with MW 1.22. It would be great, if you can upgrade, but i know, what you mean with the risks :)

> Is there away to maybe add that missing line of code to mobilefrontend or google-analytic?

Refer to Gerrit change 161457. This is the line, which you have to change :)

TimMacG (talkcontribs)

Thank you very much. I hope changing that line will work! Do you still highly suggest to upgrade the whole mediawiki? I mean considering this specific problem? Is this just a quick fix for the whole problem?

Florianschmidtwelzow (talkcontribs)

> Do you still highly suggest to upgrade the whole mediawiki? I mean considering this specific problem? No. The change get's (normally) merged into the REL1_22 branch sometime.

But if you look at the whole MediaWiki context, it is recommended to have the latest stable version installed, which is actually MW1.23. 1.22 is still supported, but only for legacy reasons :) To get the whole bunch of new and improved features (and not "only" the critical bug and security features) you should invest some time, if MW1.23 is working with your actual setup, too. And if so: Upgrade :)

Reply to "[RESOLVED] Mobilefrontend and google-analytics"