Topic on Project:Support desk

Jump to: navigation, search

[RESOLVED] MediaWiki don't work with PCRE 8.34

4
87.252.72.81 (talkcontribs)

I was running MediaWiki 1.20.8 with no problems. Then after upgrading PCRE from version 8.33 to 8.34, the content on most of the pages in my MediaWiki site does not display, only empty pages without content. Then I upgraded to MediaWIki 1.22.0, but the same problem still exist there.

The Apache Error Log shows many lines like this (note there is different line numbers in the errors, so its not only line number 902 like in this example) (I have changed the domain name and user name and ip from the error):

[Wed Dec 18 14:07:46.351691 2013] [:error] [pid 8193] [client 12.12.12.12:53455] PHP Warning: preg_match(): Compilation failed: group name must start with a non-digit at offset 8 in /home/xxx/domains/xxx.com/public_html/w/includes/MagicWord.php on line 907, referer: http:// xxx.no/w/index.php/Hovedside

Then I look at PCRE 8.34 changelog at pcre.org/news.txt wich says this:

"Perl no longer allows group names to start with digits, so I have made this change also in PCRE."

Please look into this and make MediaWiki compatible with newest PCRE 8.34

Also, please help me about what changes I need to do in order to patch this problem manually in MagicWord.php, so that I don't have to downgrade PCRE, please help.

88.130.117.159 (talkcontribs)

Thanks for the very good problem description!

I have just checked the bugtracker and here already is an issue about this problem:

https://bugzilla.wikimedia.org/show_bug.cgi?id=58640

Please add your findings there, especially this:

Then I look at PCRE 8.34 changelog at pcre.org/news.txt wich says this:
"Perl no longer allows group names to start with digits, so I have made this change also in PCRE."
Lucy Tech (talkcontribs)

The patch on the link above and running php update.php fixed this issue for me. Thanks for directing us to the correct place.

Bennylin (talkcontribs)

Thanks for the patch