Extension talk:Facebook

From MediaWiki.org
Jump to: navigation, search
An archive box
Archives
Archive 1

Example wiki[edit | edit source]

Is there an example wiki I can look at that uses this extension? Leucosticte (talk) 08:17, 26 October 2013 (UTC)

$wgEmailConfirmToEdit and $wgEmailAuthentication conflict[edit | edit source]

I run a private wiki that only users can edit. I want to allow people to create an account or use Facebook connect. But if they create an account I want them to have a confirmed email to edit. When I set the two variables to true to allow that, it then prevents Facebook users from editing. Is there any way around this?

Special:Connect/Debug returning <facebook-error-needs-convert> + Fatal error: Class 'SpecialPageFactory' not found error[edit | edit source]

Hi.

I have version 4.0.6stable installed on MW 1.19.5. When I go to the Special:Connect/Debug page I see <facebook-error-needs-convert> I assume this means something is not working right. I following the installation guide. What does this error mean?

I'm also seeing Fatal error: Class 'SpecialPageFactory' not found in /var/www/webapps/iow/extensions/Facebook/SpecialConnect.php on line 90 error when calling Special:Connect&returnto=Around_Isle_of_Wight

Any idea what the problem is here?

Thanks! Mitchelln 12:08, 5 November 2013 (UTC)

Breaks all Javascript used in Semantic Mediawiki[edit | edit source]

Whenever I enable this extension, all javascript lists, result formats, and maps used by Semantic Mediawiki are broken. Any ideas of how to fix this? Thanks

FIXED: I disabled opengraph in the facebook extension's settings file, and that allowed login without breaking any javascript.

Broken on MW 1.21?[edit | edit source]

I'm having a hard time getting it to work on MW 1.21 When I click login with facebook, a window appears for a very short time and nothing happens. Any help would be greatly appreciated.

Broken in 1.22[edit | edit source]

This extension should be updated to not to use ExternalUser, wich is deprecated. It should use AuthPlugin. Also, getPageTitle seems to be not implemented in 1.22, only in 1.23. It might use one or another depending on the version. --Krusher (talk) 12:37, 9 February 2014 (UTC)