User talk:Jimbojw

From MediaWiki.org
Jump to navigation Jump to search

Meta tags in general?[edit]

Would you consider updating your MetaKeywordsTag extension to support other meta tags in general? Maiden taiwan 01:21, 26 March 2007 (UTC)

Perhaps - what do you have in mind? --Jimbojw 05:39, 26 March 2007 (UTC)

KeepYourHandsToYourself[edit]

I have tested this in MediaWiki 1.10.0rc2 and get the following warning:

Warning:  Cannot modify header information - headers already sent by (output started at /home/roberthl/public_html/mediawiki-1_10/extensions/KeepYourHandsToYourself.php:97) in /home/roberthl/public_html/mediawiki-1_10/includes/WebResponse.php on line 10

Thought you might be interested. Lcarsdata 22:15, 4 May 2007 (UTC)

Thanks Lcarsdata - Make sure there are no trailing newlines at the end of the file. I think that is what's causing the issue. Try opening it in something other than Notepad or Wordpad and check the bottom of the file. Removing the '?>' may also help. --Jimbojw 05:19, 7 May 2007 (UTC)


Hi, Jimbojw,

I tried this extension on 1.10, it just does not work, nothing happens, use can still edit any other user's pages, does this extension really support 1.10? thanks a lot!--Italways 10:04, 21 November 2007 (UTC)

Hello Italways, it works just fine for me, but in my setup it's the only userCan hooking extension I'm running. You're probably seeing a conflict with another extension. Someone has already suggested to me a fix for this, which I'm testing now. --Jimbojw 17:53, 26 November 2007 (UTC)
Update: I updated the script with the suggested fix - I'd be interested to hear if this resolved the issue. Also, the new version features user-specific images (in case users want to upload uneditable images). --Jimbojw 18:08, 26 November 2007 (UTC)

I can't access to this web sit it's off line. Can anybody send me this extensions by e-mail eddysdiaz08@gamil.com. Thanks --Thorack 17:54, 22 December 2010 (UTC)

Extension:YouTubeTag[edit]

YouTube allows parameters to control certain aspects of the embedded video, such as &rel=0 to disable the display of related videos, and an option &autoplay=1 to autoplay. Currently the extension does not recognise these parameters, any chance of doing so? --84.9.191.165 20:50, 29 August 2007 (UTC)

Hello! I have deprecated Extension:YouTubeTag in favor of the much more flexible and powerful Extension:EmbedVideo, so I probably won't entertain any feature requests for YouTubeTag. That said, incorporating those additional parameters into EmbedVideo would probably not be so bad. You could edit the services list to incorporate those params directly, then call {{#ev}} with the new "service". For example, you could have "youtube_autoplay" which would be called like this: {{#ev:youtube_autoplay|...}}. Hope this helps! --Jimbojw 16:00, 5 September 2007 (UTC)
Thanks, I'll give it go. --84.9.191.165 16:41, 5 September 2007 (UTC)

Mediawiki Skin[edit]

Hi - I like the layout of your mediawiki site at jimbojw.com. I am wondering if you make your mediawiki skin available for download somewhere. I think your layout would work well with my site also. --Rovo 12:18, 10 September 2007 (UTC)

Thanks Rovo! It has been on my todo list for quite some time to update my MW skin and release it - just never got around to it quite yet. :( --Jimbojw 05:48, 15 September 2007 (UTC)

Problem of getting of your extension source codes[edit]

Hi, I tried to get the following extensions but the site didn't load at all. I did it several times but it didn't pay either. Have a look at those links please.

I'll be expecting for solving the problem to get those source files. Thanks very much.--Soroush 20:05, 11 September 2007 (UTC)

For sure,it'll be nice of you if you solve this problem or show a better link to obtain those extensions. Thanks again.--Soroush 10:02, 12 September 2007 (UTC)
Hi Soroush! I haven't been able to reproduce that issue, and I'm not aware of any outtages on my site. If it happens again, please feel free to let me know (wilson.jim.r<at>gmail.com). --Jimbojw 05:50, 15 September 2007 (UTC)

your extension EmbedVideo.php : a patch ?[edit]

Because I get this kind of notice messages when using your extension :

 Notice: Undefined index: id_pattern in /.../extensions/EmbedVideo.php on line 131
 Notice: Use of undefined constant noparse - assumed 'noparse' in /.../extensions/EmbedVideo.php on line 156
 Notice: Use of undefined constant isHTML - assumed 'isHTML' in /.../extensions/EmbedVideo.php on line 157

I've tried to resolv them. I've added quotes on array-keys and used array_key_exists() instead of just testing $service["id_patern"]... and it gived me this patch :

--- EmbedVideo.old.php  2007-06-26 08:26:52.000000000 +0200
+++ EmbedVideo.php      2007-09-14 09:33:31.000000000 +0200
@@ -128,7 +128,7 @@
         if (!$service) return '<div class="errorbox">'.wfMsg('embedvideo-unrecognized-service', @htmlspecialchars($params['service'])).'</div>';
         
         $id = htmlspecialchars($params['id']);
-        $idpattern = ($service['id_pattern']?$service['id_pattern']:'%[^A-Za-z0-9_\\-]%');
+        $idpattern = (array_key_exists('id_patern',$service)?$service['id_pattern']:'%[^A-Za-z0-9_\\-]%');
         if ($id==null || preg_match($idpattern,$id)) {
             return '<div class="errorbox">'.wfMsgForContent('embedvideo-bad-id', $id, @htmlspecialchars($params['service'])).'</div>';
         }
@@ -153,8 +153,8 @@
         
         return array(
             wfMsgForContent('embedvideo-embed-clause', $url, $width, $height),
-            noparse => "true",
-            isHTML => "true"
+            "noparse" => "true",
+            "isHTML" => "true"
         );
     }
 
@@ -206,4 +206,4 @@
 
 } # End MW Environment wrapper
 //</source>
-?>
\ Pas de fin de ligne à la fin du fichier.
+?>

--BeTa-glop 07:43, 14 September 2007 (UTC) BeTa <beta AT e-glop DOT net> (2007-09-14)

Thanks BeTa-glop! I have corrected core issues which were causing you to receive Notices from PHP. A new version of EmbedVideo (0.1.2) has been released and is available for download. Thanks again for pointing out this problem! --Jimbojw 06:24, 15 September 2007 (UTC)

Your ArticleComments extension[edit]

Jim, I am using several of your extensions on my wiki and they work great. But I'm struggling to get the ArticleComments extension to work. I'm using MW 1.10 and have followed the install instructions. When I insert <comments /> into an article all I get is a string of code. I am using the extension "WikiPoll" from http://wikipoll.free.fr/mediawiki-1.6.5/index.php?title=Source_code. Do you think there is a conflict? Any help would be appreciated. Thank you. Nancy Dailey www.womensmoney.com

Hi Nancy, I see you got it working, or so it would appear on Talk:The Purse]. I haven't used WikiPoll, so I don't know of any conflict, but there certainly could be one. Most likely this would be caused by the other extension failing to return a proper value (as this can be fatal to other extensions). My suggestion when encountering problems like this is: try to reorder the extensions so that the improperly returning ones are at the bottom. However I understand that figuring out which ones are malfunctioning is quite a technical affair. Good luck! --Jimbojw 08:00, 20 September 2007 (UTC)

Article Comment[edit]

Article Comment is fantastic but there is one problem. The capchta, please, please can you add 'ConfirmEdit. Sachein 13:44, 14 May 2009 (UTC)

thanks alot[edit]

Hi, when picking up extensions i need, i see your name as an author again and again. I'm a fan. Just wanna say thank you and you're really a genius so generous to share your work! --Zozzen 10:17, 29 July 2009 (UTC)

id is the id of the shoutbox to display[edit]

RE: http://www.mediawiki.org/wiki/Extension:ShoutBox

What is the id? I have no idea what that means. Can you please elaborate? Thank you. Adamtheclown 04:59, 5 December 2010 (UTC)

i figured it out, and added this to the page. Adamtheclown 17:56, 25 December 2010 (UTC)

sharethis extension cannot work on Mediawiki version 1.21.2[edit]

Hi, I can seem to get the extension to work. I have follow the instruction to the letter and even changed my skin to monobook but to no avail. Could you help me out. Thanks