User:Robchurch/Troubleshooter

From MediaWiki.org
Jump to navigation Jump to search

Blank pages[edit]

Problem: Server returns blank pages (no HTML source) when viewing articles, special pages, etc.

If using the 1.8.x branch, upgrade to 1.9.x and see if that solves it. 1.8.x had some problems with our backtrace (exception) handling code and incompatibilities with some popular Zend extensions. These are fixed in the 1.9.x series.

If that doesn't fix it, break out the PHP error log; this is configured in the main PHP configuration and will often contain helpful information in cases like this. You should be able to deduce the problem from the error log entries.

Broken Special namespace[edit]

Problem: Links to pages in the Special namespace, e.g. Special:Userlogin don't seem to have the Special: prefix; viewing special pages doesn't work

You're running PHP 5.0.x on an AMD 64-bit architecture. PHP 5.0.x had a number of significant bugs with regard to negative integers and whatnot which manifested on that and possibly other architectures. These problems often start showing up in MediaWiki when running the 1.8.x series.

Upgrade to PHP 5.1.0 or above.

Uploads don't work[edit]

Problem: Special:Upload isn't available; claims that uploads are disabled

Enable uploading of images and other media; set $wgEnableUploads = true; in LocalSettings.php and reload the page.

Problem: Special:Upload complains about file permissions

Make sure that your web server software (e.g. Apache, IIS, Lighty, etc.) has permissions to read and write the images/ directory tree, and set this as necessary. Shared hosts often provide a control panel applet to allow this.