User:Legoktm/Packages

From MediaWiki.org
Jump to navigation Jump to search

I maintain packages of MediaWiki for Debian and Ubuntu. These follow the LTS cycle and are kept up to date with maintenance and security releases. In the past these packages were severely outdated, did weird things to MediaWiki like moving files around, patching random parts of the code, replacing bundled libraries with different versions, etc., to the point where it was recommended not to use them. My goal is to not do that as much as possible as allowed by the distribution's policies. In addition, I am also maintaining and updating other MediaWiki related packages like wikidiff2, luasandbox and texvc.

Supported operating systems[edit]

The package is also available in modern Ubuntu releases, starting with Yakkety Yak. These are supported for as long as the release is, and whatever Ubuntu themselves provides. For the best experience on Ubuntu, you should use my PPA instead of the official archvies.

Installation[edit]

Note that Ubuntu users will need to enable the PPA first. And then...

sudo apt-get install mediawiki

Easy right? This will install MediaWiki, PHP, a webserver (if necessary), and maybe a database server.

If you don't have a webserver installed, Apache will be installed, and automatically configure the wiki to be served at http://localhost/mediawiki/.

Note, the default Apache configuration uses mod_php. Ubuntu users will need to manually install it via the libapache2-mod-php package.

MediaWiki supports different database engines, in order of preference they are: MariaDB, MySQL, SQLite, and PostgreSQL. The package is compatible with any of them, but will recommend you install mysql-server.

You should then follow the steps in the web installer to set up MediaWiki. See the installation guide for more details.

Upgrading[edit]

When the package is upgraded, it will not automatically run update.php. It only updates the changed files in the package, which is usually enough for security releases. For major version upgrades, you should read through the upgrade guide.

Support[edit]

If you need help with MediaWiki, please see the support desk. You should also mention that you are using the Debian/Ubuntu package, and the version of the package that is installed.

If you have found a bug in MediaWiki that is not specific to the packaged version, please report a bug against the relevant MediaWiki component.

If you believe you have found a bug specific to the package or in the packaging itself, please file a bug in the MediaWiki-Debian Phabricator project. Bugs experienced on Debian may also be reported in the Debian bug tracker.

If you have other questions/concerns/suggestions, feel free to file a bug, leave a note on the talk page, or find me (legoktm) on #mediawiki on freenode.

Filesystem[edit]

Typically, MediaWiki, extensions, and configuration are all located in one folder. However, we try and follow the Filesystem Hierarchy Standard (FHS), and as a result, it is split into 3 main locations:

  • /usr/share/mediawiki - MediaWiki core files
  • /etc/mediawiki/LocalSettings.php - expected location of LocalSettings.php. You can also put other configuration files in this directory.
  • /var/lib/mediawiki - Main directory that the webserver will read from. Most core files from /usr/share/mediawiki are symlinked into this directory, and the LocalSettings.php file as well.
  • /var/lib/mediawiki/extensions - Extensions are read from this directory. Non-packaged extensions can be installed here as well.
  • /etc/mediawiki-extensions - Legacy system to enable/disable extensions and should not be used. Left around for backwards-compatibility.

Development[edit]

Interested in helping out?

Thanks[edit]

A lot of different people have helped make this project a reality. In roughly chronological order: