Topic on Project:Support desk

Jump to navigation Jump to search

Mediawiki 1.32 version not available in most of the extension

5
Frizzow (talkcontribs)

Our MediaWiki is 1.32 version and most of the extension available such as PluggableSSO, PluggableAuth, SimpleSAMLPhp and OpenIdConnect etc are not offering the version. What would be the most compatible and safer version i should choose? We would like to configure SSO for our on-prem server and hope that it wouldn’t cause much trouble if we are using a different ver. Appreciate your help!!

Jonathan3 (talkcontribs)

Pick one from here: Version lifecycle.

Depends on extension compatibility and how often you plan to upgrade :-)

Bawolff (talkcontribs)

Often you can get older versions of extensions at github. However we do reccomend you use a recent version of mediawiki.

Jonathan3 (talkcontribs)

If I were advising myself I'd say stick with one of the LTS versions, but only upgrade to it at the last safe moment so that your extensions and skin likely will have been upgraded too. I'm still on 1.34 as when I had the time to upgrade to 1.35 nothing seemed to work with it, and now that everything works I don't have the time :-)

Frizzow (talkcontribs)

Thanks for the details explanation! Currently, We don’t plan to upgrade the ver in anytime soon due to internal decision. If we would like to stay on 1.32 ver more longer and would like to use the mentioned extension for SSO ex: PluggableAuth. Can i download the latest extension version from the drop down menu like 1.36(latest stable MediaWiki) or 1.35 since the status is LTS? Or the best case is to download the same extension ver from git? I tried to find the extension ver from git but i can’t find it because i’m not very familiar with it.

Reply to "Mediawiki 1.32 version not available in most of the extension"