Topic on Talk:Phabricator/Help

Jump to navigation Jump to search

Can't access my wikitech account

12
YuviPanda (talkcontribs)

I'm trying to get back into my wikitech account after ages, and I get the following error message:


You must verify your email address to log in. You should have a new email message from Phabricator with verification instructions in your inbox ([])


I had this wikitech account (Yuvipanda) before I was at WMF, so I'd like to get it back :D

AKlapper (WMF) (talkcontribs)

@YuviPanda: Hej hej! :) https://phabricator.wikimedia.org/p/Yuvipanda/ is an active account (and linked to both LDAP and SUL accounts) and says "Email not verified", indeed. Querying the Phab DB, your email address ends with "@wikimedia.org" so it's likely invalid.

Can you manage to log into Phab by using your mediawiki.org SUL account instead (Not sure though, as Phab is linked to the SUL account called "Yuvipanda" but your account now seems to be "YuviPanda")?

YuviPanda (talkcontribs)

Hi @AKlapper (WMF) :D


Yeah, I volunteered for SUL renaming when it first came out, so my SUL entry is kinda screwed up. When I try to login with SUL, it tells me it's going to create a new account. And when I try to do that, I get:

  • Another user already has that username.
  • Another user already has that email.


Even though this email is yuvipanda@gmail.com

AKlapper (WMF) (talkcontribs)

@YuviPanda I think the underlying problem to first sort out here is your wikitech/LDAP account if you cannot log into wikitech. That would be the Cloud Services folks, presumably. :)

Majavah (talkcontribs)

@AKlapper (WMF) I understood that Yuvi has access to Wikitech, but Phabricator still has the old email somewhere and is Yuvi can't do anything unless that old email (that he can't access) is verified, which is not possible.

AKlapper (WMF) (talkcontribs)

Hmm, might be... As a Phab admin I cannot change the email address of a Phab account in the UI. This would require directly editing the DB. I don't have permissions to do that.

UPDATE phabricator_user.user_email SET address = "ThatNewAddress" WHERE userPHID = "PHID-USER-2nnm76h4ykalvvref2ye"; basically.

@MModell (WMF) Any better ideas? If not, who could do that?

AKlapper (WMF) (talkcontribs)

(Plus I'm wondering if this needs an additional verification check, as the Phab account has some non-default permissions... what do I know.)

MModell (WMF) (talkcontribs)

@AKlapper (WMF) @YuviPanda: I see both email addresses in phabricator and they are both associated with the same user PHID. I'm going to try switching which address is listed as 'primary' and maybe that will fix the issue.

MModell (WMF) (talkcontribs)

@YuviPanda: Can you try logging in now that I've changed your primary address to the non-wmf one?

AKlapper (WMF) (talkcontribs)
YuviPanda (talkcontribs)
MModell (WMF) (talkcontribs)

You're welcome! And welcome back! :)