Topic on Talk:Parsoid

Jump to navigation Jump to search
S0ring (talkcontribs)

I used to install Parsoid for MW 1.31 (supported until June 2021) with:

# git clone --branch v0.10.0 https://gerrit.wikimedia.org/r/p/mediawiki/services/parsoid /usr/lib/parsoid

but the URL is no longer valid, it returns 404. How to install it?

Arlolra (talkcontribs)
S0ring (talkcontribs)
S0ring (talkcontribs)

This works # git clone --branch v0.10.0 https://github.com/wikimedia/parsoid.git

Arlolra (talkcontribs)
S0ring (talkcontribs)

This URL returns the following error:

# git clone --branch v0.10.0 https://gerrit.wikimedia.org/r/admin/repos/mediawiki/services/parsoid /usr/lib/parsoid

Cloning into '/usr/lib/parsoid'...

fatal: https://gerrit.wikimedia.org/r/admin/repos/mediawiki/services/parsoid/info/refs not valid: is this a git repository?

Arlolra (talkcontribs)