Topic on Project:Support desk

Jump to navigation Jump to search

MediaWiki 1.35.x CategoryTree in Sidebar not working

7
Hags343 (talkcontribs)

Hi,

I've a clean installation of MediaWiki 1.35.0 on Ubuntu 20.04. I've also tried the new version 1.35.1 (installed via patch), but I do not get the CategoryTree displayed in the sidebar. I followed the instruction from the following wiki page: Extension:CategoryTree#Using CategoryTree in the Sidebar


This are the new lines in the LocalSettings.php:

$wgCategoryTreeSidebarRoot = 'Category:forest';

$wgCategoryTreeForceHeaders = true;


If I open the page, I get the error Category not found, but the category exists. I've uploaded some screenshots and the configuration file LocalSettings.php here: https://www.dropbox.com/sh/w2bg2gxmf9th6vl/AACcJEkKeERNBCNedPJJ47CRa


Does anyone have any idea what the problem could be?

If anyone has a working configuration with the latest version, that would help me a lot too.


Thank you very much.

Bawolff (talkcontribs)

idk, is it supposed to have the Category: prefix?

Hags343 (talkcontribs)

I've also tried it without the prefix or even with a normal page.

Jonathan3 (talkcontribs)

Did you add the function AppendCategoryTreeToSidebar code too?

Hags343 (talkcontribs)
Jonathan3 (talkcontribs)

Stick it in the wiki page called MediaWiki:Common.js and see what happens.

Hags343 (talkcontribs)
Reply to "MediaWiki 1.35.x CategoryTree in Sidebar not working"