Topic on Talk:Quarry

Jump to navigation Jump to search

need help / quarry does not start at all

3
ISO 3166 Bot (talkcontribs)

Hi

https://quarry.wmflabs.org/query/50304 does not start at all (since a few days). Before that ( made some change) it ran and produced sound results without any timeout. See similar https://quarry.wmflabs.org/query/50070 , whích ran and where the result is still in the cache.

There are two selects, running only the first will start and finish. Running only the second will not start. without any hint or error message, it just fails silently.

Can somebody help to find / fix the problem? best


Try https://quarry.wmflabs.org/query/50253 (quarries that are not executed are not safed, so https://quarry.wmflabs.org/query/50304 is empty). Was empty, I now played around a little bit and it seems that there is a size limitation for the sql script, / for each select statement.

got the following messages in the console:

/api/query/run:1 Failed to load resource: the server responded with a status of 500 ()
50304:1 Refused to load the image 'data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==' because it violates the following Content Security Policy directive: "img-src 'self'".
/api/query/run:1 Failed to load resource: the server responded with a status of 500 ()
jquery.js:8623 POST https://quarry.wmflabs.org/api/query/run 500
send @ jquery.js:8623
ajax @ jquery.js:8152
n.<computed> @ jquery.js:8298
(anonymous) @ view.js:80
dispatch @ jquery.js:4409
r.handle @ jquery.js:4095


(its chrome)

message for status 500 is:

500 Internal Error

Sadly Quarry is currently experiencing issues and is unavailable. Please try again later.

But I have to dig into the browser debugger to see this. No message on the UI.

Framawiki (talkcontribs)

Hi @Herzi Pinki:, could you re-try now? If it's working, it was probably a temporary issue.

Herzi Pinki (talkcontribs)

Thanks, it is working now.

For a temporary issue it took quite long to fix it. It would be an improvement, if a status of 500 is propagated to the UI anyway.

Reply to "need help / quarry does not start at all"