Topic on Project:Support desk

Jump to navigation Jump to search

Upgrade steps from really old version

18
JohnAintree (talkcontribs)

I've been trying to upgrade this for a week - we moved our old wiki from 2008 to 2016 server now I need upgrade php for security reasons after an audit -


I have looked at the compatibility list in great detail and found every time I wen t to 1.35 from 1.23 it failed - I managed as below to go to a middle step -


Perhaps I am jumping to far ahead - we are on 1.23 and PHP 5.4.23 and MySQL 56 - I want to go to MW 1.35 PHP 7.4 and mysqL56 - can I do this in one go. I have tried about 10 times now I can get to MW1.30 PHP 7.1.329 - I'm missing something - do I need upgrade in steps or go straight.

We are on Windows 2016 and IIS - I am no php expert - its driving me mad - - been at this a week -

Malyacko (talkcontribs)

If there is an error then please tell us the error message.

JohnAintree (talkcontribs)

There is no error on HTTP -500 and a blank page - the roro I think is in PHP as I get to the you must upgrade PHP page then I do the I get nothing -

204.113.253.88 (talkcontribs)

Go Here and you'll see that Php 7.4 to 7.4.2 is not supported

Maybe that will help

This post was hidden by Bawolff (history)
204.113.253.88 (talkcontribs)

Sorry, I don't mean to spam, I accidently posted it twice

Bawolff (talkcontribs)

enable php error reporting or check your php error log.

See How to debug

JohnAintree (talkcontribs)
JohnAintree (talkcontribs)

OK I am copying 1.35 over the top of 1.23 -

MediaWiki 1.35 internal error

MediaWiki 1.35 requires at least PHP version 7.3.19; you are using PHP 5.4.30.

Supported PHP versions

Please consider upgrading your copy of PHP. PHP versions less than v7.2.0 are no longer supported by the PHP Group and will not receive security or bugfix updates.

If for some reason you are unable to upgrade your PHP version, you will need to download an older version of MediaWiki from our website. See our compatibility page for details of which versions are compatible with prior versions of PHP.


Ok now I change to

7.3.19

The website cannot display the page

HTTP 500

Most likely causes:

  • The website is under maintenance.
  • The website has a programming error.

What you can try:

JohnAintree (talkcontribs)

Fatal error: Uncaught Error: Class 'AuthPlugin' not found in C:\inetpub\wwwroot\itkb\extensions\LdapAuthentication\LdapAuthentication.php:131 Stack trace: #0 C:\inetpub\wwwroot\itkb\LocalSettings.php(140): require_once() #1 C:\inetpub\wwwroot\itkb\includes\Setup.php(143): require_once('C:\\inetpub\\wwwr...') #2 C:\inetpub\wwwroot\itkb\includes\WebStart.php(89): require_once('C:\\inetpub\\wwwr...') #3 C:\inetpub\wwwroot\itkb\index.php(44): require('C:\\inetpub\\wwwr...') #4 {main} thrown in C:\inetpub\wwwroot\itkb\extensions\LdapAuthentication\LdapAuthentication.php on line 131

JohnAintree (talkcontribs)

I backed up localsettings.php now can progress


but fails here

An error occurred:

Error 1091: Can't DROP 'img_user_timestamp'; check that column/key exists (localhost)

Function: Wikimedia\Rdbms\Database::sourceFile( C:\inetpub\wwwroot\itkb/maintenance/archives/patch-drop-image-user-fields.sql )

Query: ALTER TABLE `image`

DROP INDEX img_user_timestamp,

DROP INDEX img_usertext_timestamp,

DROP COLUMN img_user,

DROP COLUMN img_user_text,

ALTER COLUMN img_actor DROP DEFAULT

JohnAintree (talkcontribs)

This is indeed painful - and difficult to install -

JohnAintree (talkcontribs)

Uncaught Error: Class 'AuthPlugin'

[26-Nov-2020 18:54:19 Europe/Minsk] PHP Fatal error:  Uncaught Error: Class 'AuthPlugin' not found in C:\inetpub\wwwroot\itkb\extensions\LdapAuthentication\LdapAuthentication.php:131

Stack trace:

#0 C:\inetpub\wwwroot\itkb\LocalSettings.php(4): require_once()

#1 C:\inetpub\wwwroot\itkb\includes\Setup.php(143): require_once('C:\\inetpub\\wwwr...')

#2 C:\inetpub\wwwroot\itkb\includes\WebStart.php(89): require_once('C:\\inetpub\\wwwr...')

#3 C:\inetpub\wwwroot\itkb\index.php(44): require('C:\\inetpub\\wwwr...')

#4 {main}

  thrown in C:\inetpub\wwwroot\itkb\extensions\LdapAuthentication\LdapAuthentication.php on line 131

Bawolff (talkcontribs)

LdapAuthentication doesnt support your version of mediawiki. You need to use LdapAuthentication2.

JohnAintree (talkcontribs)

[27-Nov-2020 12:56:04 Europe/Minsk] PHP Parse error:  syntax error, unexpected '=>' (T_DOUBLE_ARROW) in C:\inetpub\wwwroot\itkb\LocalSettings.php on line 187

JohnAintree (talkcontribs)

Totally give up - will stay on version 1.23 - for ever

JohnAintree (talkcontribs)

Thanks everyone for the help I have been at this for 2 weeks and frankly I have had enough on e problem leads to the next - the wiki functions on version 1.23 and is only hosted internally - there has been problem after problem upgrading the version and PHP at the same time it seems impossible.

I'd like to thank you all for the help -

I am a systems engineer not a PHP coder -

I feel I have come to the end of the line o this and can spare no more time.

Reply to "Upgrade steps from really old version"