Topic on Project:Support desk

Patch 1.31.10 on top of 1.31.9

2003:ED:5F08:BA00:6834:1E7D:E728:D27B (talkcontribs)

Hi, I applied first the patch 1.31.9 on top of the 1.31.8 which worked well and afterwards the 1.31.10 on top of the 1.31.9. The latter didn't work. I get the following message:

checking file includes/ActorMigration.php

checking file includes/Defines.php

checking file includes/user/User.php

Hunk #1 FAILED at 2528.

1 out of 1 hunk FAILED

checking file RELEASE-NOTES-1.31

checking file tests/phpunit/includes/ActorMigrationTest.php

Does anybody have an idea, where I can start to fix this issue? (talkcontribs)

I discovered, that the filenames last letter of about 180 files seems to be missing in 1.31.10. See here. Let's take ActionMigration.php for example. I do not know from here, if this particular file is affected, but if it is, then the filename is in V1.31.10 and not ActionMigration.php. Maybe this explains your issue?

Bawolff (talkcontribs)
Leeshore1966 (talkcontribs)

I have the same issue

Malyacko (talkcontribs)
Reedy (talkcontribs)
Reedy (talkcontribs)
2003:ED:5F06:3600:9174:1E6D:2D3A:382B (talkcontribs)

Thank you Reedy, that worked! (talkcontribs)


first time applying patches instead of just copying the new release on top of the old one.

I get the following message:

$ patch -p1 --dry-run < mediawiki-1.31.10-fixup.patch

checking file includes/ActorMigration.php

checking file includes/api/ApiMain.php

Reversed (or previously applied) patch detected!  Assume -R? [n]

What should i do here?


Reply to "Patch 1.31.10 on top of 1.31.9"