Topic on Talk:Talk pages project

Jump to navigation Jump to search
Bluetpp (talkcontribs)

The tool has just been deploited on Vietnamese wikipedia, and after I've turned the feature on on the beta feature preference, I tried replying to some comments. After clicking into the reply button, that button disappeared but the reply box was nowhere to be found, and also all the other reply button turned into gray. What's wrong? Please help me.

Edit 1: Okay, it seems that other users in my wiki can still use the feature... but after I changed the browser the problem is still there.

Edit 2: After further testing I realized that the problem only appears if I click the reply button of the lastest comment. It'll be fine if it's not the lastest comment. What's wrong though?

Matěj Suchánek (talkcontribs)
Bluetpp (talkcontribs)

@Matěj Suchánek Okay, I tried purging, nothing changed. but I tried adding "?safemode=1" and voila, the reply box appears.

I follow the guide and there's indeed an issues on the "Console" tab but I cannot find the "Debugger" tab. Help me...

Matěj Suchánek (talkcontribs)

You probably don't need the debugger (if you want it, search the internet for how to find it in your browser), the console should tell you enough (especially with debug=1). Note that the console will also likely show some warnings but you are looking for "errors".

Bluetpp (talkcontribs)

I don't understand a single things in this image, can you please help me and take a look at it? I see that it has 2 errors...

Matěj Suchánek (talkcontribs)

Twinkle[module] is not a function points me to vi:MediaWiki:Gadget-Twinkle.js. It's quite worrying a project-wide gadget breaks, you should probably contact users who ported it to your wiki and tell them about this problem.

Cannot read property 'style' of null points to vi:MediaWiki:Gadget-AVIM.js, again a project-wide gadget. It's possible it needs be updated to work with DiscussionTools.

Whatamidoing (WMF) (talkcontribs)

Bluetpp, would you please check this idea, by going to https://vi.wikipedia.org/wiki/Đặc_biệt:Tùy_ch%E1%BB%8Dn#mw-prefsection-gadgets and turning off Twinkle? (I use AVIM at viwiki, and the Reply tool works for me there, so I think AVIM is not the cause of the problem.) Please try turning off Twinkle, check for the Reply tool on a few pages, and then let me know whether it made a difference. (And then turn Twinkle back on, if you want to.)

ESanders (WMF) (talkcontribs)

We were able to post with Twinkle enabled: diff.

Bluetpp (talkcontribs)

@Whatamidoing (WMF) Hi, I'm the one asking you to exploit the tool in viwiki. So I've turned off Twinkle but it doesn't fix anything.

In [[:vi:Wikipedia:Thảo_luận#[TH%C3%94NG%20B%C3%81O]%20T%C3%ADnh%20n%C4%83ng%20beta%20m%E1%BB%9Bi:%20C%C3%B4ng%20c%E1%BB%A5%20th%E1%BA%A3o%20lu%E1%BA%ADn|this]] talk topic, somebody points out that if he replies to other comment first (not the lastest and with the deepest indent one) and then not refresh the page, he can then reply to the lastest comment.

@Matěj Suchánek Thanks, I'll try doing what you told and I'll update later.

Wargo (talkcontribs)

Did you try on your second account? Important: open the console before you click reply button and see what error messages income. Probably another gadget is problem.

Bluetpp (talkcontribs)
Error with Reply tool 1
Error with Reply tool 2

@Wargo Okay, I did what you told, used 2nd account, open the console before clicking reply button. Here it is:

Matma Rex (talkcontribs)
Bluetpp (talkcontribs)

@Matma Rex Yes! After turning the "comments in local time" off, it's back to normal! So what can I do? This is a massive bug isn't it?

Wargo (talkcontribs)

This gadget adds time tag. I think it will be easy to implement recognization of this. Maybe normal timestamp should also have these tags? ;)

PPelberg (WMF) (talkcontribs)

@Bluetpp we appreciate you making us aware of this issue and thank you, @Matěj Suchánek and @Wargo for helping us all identify the cause(s) of it.

The editing engineering team investigated this issue today and has come to think the following: it is possible for the Reply Tool to be enhanced so it can be compatible with the "Tin nhắn theo giờ địa phương" (Comments in local time) gadget @Matma Rex linked to above.

Said "enhancement" is described in this task: phab:T252555. However, it is likely this enhancement will not reach Vietnamese Wikipedia, and subsequently resolve the issue being discussed here, for a few weeks.

This means that in the meantime, you'll need to disable the "Tin nhắn theo giờ địa phương" (Comments in local time) gadget in order to use the Reply Tool (not ideal, we know :/ )

Please let us know if anything above prompts new thoughts or questions and thank you again for working with @Matěj Suchánek and @Wargo to figure out what was causing this issue.

PPelberg (WMF) (talkcontribs)

@Portal18 and @ネイ, I'm tagging you both here because I wanted you to be aware that we think the issue you were discussing here [i] will also be resolved by the fix we are implementing as part of phab:T252555.

---

i. Topic:Vu9kty6l1yu9i75i: Cannot use with "Change UTC-based times and dates, such as those used in signatures" Gadget

Reply to "Reply box does not appear"