Topic on Extension talk:PdfHandler

Jump to navigation Jump to search

PDFs won't display, MW shows security warning error

5
Woozle (talkcontribs)

I had this extension installed and working on two wikis. After upgrading each at different times (to 1.31.7 and 1.32), I later noticed that it is no longer rendering them on File: pages or anywhere else, and the File: pages now show a pop-up security warning (when you hover over the "application/pdf" text) which links to Special:MyLanguage/Help:Security/PDF_files -- but that page has no information about suppressing the warning.

I'm thinking that whatever is triggering the warning is preventing the extension from rendering the files, but I haven't been able to find any information about how to change that.

Does anyone have any information about this?

Thanks.

Dinoguy1000 (talkcontribs)

The first thing to do is to make sure your extensions are up to date as well.

The warning is about generic issues with the PDF format as a whole and has nothing to do with the configuration details of any individual website. It also shouldn't prevent the preview from displaying (see for example commons:File:JUA0680291.pdf, where both a preview of the PDF and the warning popup are visible). You should be able to hide the warning via CSS, though I've never done this myself so I can't advise on what classes or IDs you need to use. Unfortunately I can't provide any help with why the previews aren't displaying for you; I've had the same issue on a wiki of mine for a while.

Woozle (talkcontribs)

Another extension does seem to have been causing the issue in at least one wiki, though it's not clear how the two were interfering with each other. Still investigating -- but PDFs on that wiki seem to be rendering properly now.

Dinoguy1000 (talkcontribs)

Which extension?

Woozle (talkcontribs)

I think it was one of mine, not one that MW distributes.

Reply to "PDFs won't display, MW shows security warning error"