Topic on Project:Support desk

Jump to navigation Jump to search

Getting multiple (3 times) authentication requests by .htaccess

6
Easterevening (talkcontribs)

Hi,

when entering the URL of the wiki, it asks three times for the login data by my .htaccess and .htpasswd, it should only once.

I first thought because of the logo file, but editing the LocalSettings.php Manual:$wgLogo nothing changed.

What other reasons could cause it? Or what to do, to find it out? Thank you.

Easterevening (talkcontribs)

When deleting the image file under /resources/assets/wiki.png the multiple (3 times) login requests by .htaccess is solved. Now logo. in my LocalSettings.php is working. Thank you.

Easterevening (talkcontribs)

It seems not completely solved. Now the authentication window appeared two times. It looks connected with loading the logo.png file? What else to do? Thanks.

Bawolff (talkcontribs)

this is more a question for an apache support form. Are you using different realms or something gor different resources, or are they on different domains?

Easterevening (talkcontribs)

MediaWiki 1.34.1

Everything is under mydomain.com/wiki/

After first authentication window the wiki site appears, but without the logo. Than it needs to confirm a second authentication window and than also the logo appears in left upper corner..

I us in LocalSettings.php this:

$wgLogo = $wgScriptPath . '/images/mylogo.png';

as mentioned "below the definition of $wgScriptPath!"


Now, I was putting the original mediawiki logo under /resources/assets/wiki.png

Than the authentication window appears again three times. Even when I rename it to wiki.png_not

Only when I rename also the logo under '/images/mylogo.png_not, so no logo is showing in left upper corner, the authentication window appears only two times. I wonder, still two times Thanks.

Easterevening (talkcontribs)
Reply to "Getting multiple (3 times) authentication requests by .htaccess"