Topic on VisualEditor/Feedback

Publish changes and switch to Source editing didn't work on specific page

Summary by Whatamidoing (WMF)
Jhertel (talkcontribs)

On 22 March 2020, on the Danish Wikipedia, the page couldn't be edited with VisualEditor. Or rather, when you edited something on the page with VisualEditor, and then pressed "Publish changes..." (which was not greyed out or disabled), it had no effect. Trying to switch to "Source editing" had no effect either; nothing happened when you clicked the menu item. So you effectively lost your edits, which you only discovered after having finished your edits and wanting to save.

There were no problems editing any other articles I tried at the time.

If I edited the page in "source code" mode from the start, there were no problems.

So there was something about that specific page that disabled the function of the mentioned button and the mentioned menu item, or made them fail quietly.

I asked other Danish editors, and the problem appeared to them too on the specific page.

Today I tried again, and now it worked. I checked the history, and some changes had been made, partly to attempt to make VisualEditor work. Specifically this change, where a reference name was changed, was described as having that purpose in mind. Whether that specific change was the one that did it, I don't know.

Even though the problem is not present now, there is still a bug in VisualEditor, as it should be able to gracefully handle any page, at least giving an error message in cases it can't handle (which should happen before the user starts editing and not after).

Weblars (talkcontribs)

I have more details about the problem. When the character 0xA8 (see ISO/IEC 8859-1) is used inside a reference name, for example <ref name="something"/> the problem arises. The character was invisible in the article, but I could see it in the html-source code of the page as "%A8". I hope this explanation will be helpful when making VisualEditor able to handle this kind of character.

Reply to "Publish changes and switch to Source editing didn't work on specific page"