Topic on Extension talk:VisualEditor

Jump to navigation Jump to search

VisualEditor/Parsoid compatibility

4
S0ring (talkcontribs)

Parsoid/JS v0.11.0 has been released but no documentation explain the compatibility with VisualEditor.

For ex. in MW1.31.6(LTS) VisualEditor 0.1.0 is not compatible with Parsoid 0.11.0:

HTTPError 406 Not acceptable profile=\"https://www.mediawiki.org/wiki/Specs/HTML/2.1.0\"

It would be helpful to update the compatibility matrix: Extension:VisualEditor#Set up a Parsoid service

Jdforrester (WMF) (talkcontribs)
S0ring (talkcontribs)

Thank you for pointing me to the right documentation, I assume Parsoid 0.11.0 is compatible for MediaWiki 1.33 or greater, although it will be end-of-life in June 2021 at the same date with MediaWiki 1.31 LTS (and with Node10).

In MW1.31 VE0.1.0 + Parsoid 0.10.0 are working fine (which includes an important fix for external links https://phabricator.wikimedia.org/T198511), but when RESTBase (for other services like Extension:ElectronPdfService or Extension:Math/Restbase) will be installed, then it will fail similar due to Parsoid HTML version incompatibility:

HTTPError 406 Not acceptable "requested_version":"1.6.0","existing_version":"2.0.0"

Parsoid 0.10.0 is breaking the current MediaWiki 1.31 LTS with RESTBase installed locally (master branch), is there any workaround to avoid it?

Jdforrester (WMF) (talkcontribs)

Yes, the content version compatibility checks are done by RESTBase, so you don't notice the breakage until it's installed. You shouldn't use such a new version of Parsoid, but instead the one that emits version 1.6.0 of the DOM, which is the content type that VisualEditor for 1.31 supports; apparently this is Parsoid 0.9.0 according to those notes, sorry.

Reply to "VisualEditor/Parsoid compatibility"