Topic on Project:Support desk

Jump to navigation Jump to search

Can't upload a Powerpoint file due to extension mismatch?

4
106.132.203.73 (talkcontribs)

Hello I am trying to upload a powerpoint to my wiki. The powerpoint has the file type extension .ppt. But, I keep getting this error message: File extension ".ppt" does not match the detected MIME type of the file (application/zip).

Please help me fix this issue. I feel like uploading a presentation file should be simple, but I can't seem to fix this easily.

Bawolff (talkcontribs)

are you sure the extension isnt supposed to be pptx? Try renaming the file to pptx before upload

106.132.212.13 (talkcontribs)

The file was originally a pptm. The site I am uploading to only accepts .ppt, so I used Powerpoint Export to change the file to .ppt and then tried to upload it. As I said above, it still didn't work. I decided to create a blank .ppt file and copy over the slides, and the wiki let me upload this.

Thank you for trying to help! I wish I understood what was wrong with the converted file, but as long as I can share the info, it is fine.

Bawolff (talkcontribs)

Based on your description, it sounds like when you tried to convert it from pptm -> ppt, it only renamed it, and didn't actually convert it. MediaWiki detected it wasn't actually a ppt file so rejected it (pptm & pptx are zip based formats, which is probably why MW is saying it is application/zip. ppt is a much older format, and is not based on zip)

Reply to "Can't upload a Powerpoint file due to extension mismatch?"