Topic on Project:Support desk

Jump to navigation Jump to search

Upload: Thumbnails of archived versions are missing [solved]

8
Wikinaut (talkcontribs)
Bawolff (talkcontribs)

If its all files of a type, that would suggest an issue with image magick. Possibly hitting memory limits and MW for some reason isn't detecting that the render failed and thinking its succesful and using the resulting file. Check $wgMaxShellMemory, and other variables related to sandboxing the convert process. Check also the debug log for the exact command used, and see if it succedes if you type that exact command out on the command line.

If its only one file, i'd say something wrong with that file.

Wikinaut (talkcontribs)

The archived files are also only 3 bytes big.; however, as I know (from many former installations) the impact of $wgMaxShellMemory, I will frist check this setting and report here later again.

Wikinaut (talkcontribs)

Analysis:

  1. I don't see any apparent problems in the log file
  2. $wgMaxShellMemory was already set to 600000 is now 1000000 which is huge already.
  3. I "reverted" (link on the image description page https://events.ccc.de/congress/2019/wiki/index.php/File:Wikilogo.png ) to some of the previously uploaded files (which were not linked - see my page), but, surprise, surprise, where then resurrected, something, which I do not understand.
Bawolff (talkcontribs)

3 bytes is not even the size of the PNG header, so probably its just outputting the first part of the header before even doing anything related to resizing the file.

Wikinaut (talkcontribs)

At the moment, I don't even know where to start looking... For much older MW versions I found some remarks about an /images/temp directory.

Let me know, if you have another idea how to fix this issues (it's a FreeBSD server FreeBSD 12.0-RELEASE-p10 FreeBSD 12.0-RELEASE-p10 GENERICĀ  amd64 and php is 7.2.23.)


Product Version MediaWiki 1.31.3 (9aab7fc) PHP 7.2.23 (apache2handler) MySQL 5.7.27-log ICU 64.2

Bawolff (talkcontribs)

Try and fish out from the debug log the exact command used to resize the thumb, and try doing it from the commandline (sudo as the apache user) and see what happens.

limit.sh is probably more well-tested on linux than bsd, perhaps there is a bug in it that only shows up on bsd.

Wikinaut (talkcontribs)

Issue is solved. Reason was a lurking and simply wrong .htaccess file in the root of the server's documentroot which throw error 404 on access to "/archive*":

was: RedirectMatch 404 /archive

#RedirectMatch 404 /archive