Topic on User:Sokote zaman

Jump to navigation Jump to search
Sokote zaman (talkcontribs)

I can't seem to get the syntaxhighlight extension to work properly. It does show up as an installed extension on my Version page


محصول نسخه
MediaWiki 1.33.0 (7a3f860)

‏۱۲ سپتامبر ۲۰۱۹، ساعت ۱۶:۰۱

PHP 7.2.22 (cgi-fcgi)
MariaDB 10.3.17-MariaDB
ICU 64.1
Lua 5.1.5

unfortunately my server is behind a firewall and not available to the public

The odd behaviors I'm seeing are:

1) every piece of code I try to highlight gets categorized in "Pages with syntax highlighting errors", which, from my understanding of the documentation means the language tag is not recognized. I am trying to use

<syntaxhighlight lang="sql" line="1">select sysdate from dual;</syntaxhighlight>

but even code block examples I've used from the documentation get categorized the same way. It's almost as though there is no language support being loaded. I've tried php and python and the result is the same.

2) no line numbering appears.

I wouls appreciate any suggestions. I am at a complete loss as to what to do. I've even tried several other syntax highlighter extensions but they all seem to have their problems.

Alex Gorbatchev's Syntax Highligher seems to be missing the SyntaxHighlighter.php file from the download bundle

Paul Grinberg's Code Extension causes the Version page to not load

I am using the dark vector.css overlay, which could affect color, but I should think I wouldn't get every page categorized as having syntax highlighting errors.

Thanks in advance.

Reply to "syntaxhighlight"