Topic on Project:Support desk

Jump to navigation Jump to search
151.165.212.150 (talkcontribs)

I read in the Upgrade Manual to upgrade to MediaWiki version 1.32 that the PHP version should be 7.2. My current MediaWiki version is 1.23 with PHP version 5.23.28. Can I just upgrade PHP to 7.2 and then upgrade MediaWiki to 1.32?

Scott216 (talkcontribs)

According to this graph, no you can't. PHP 7.2 is compatible with 1.31+

Compatibility#PHP

I recently upgraded from 1.24 to 1.32. At first it didn't work because I needed to install new version of my skin (Vector), I also needed to modify the LocalSetting.php file to load the skins the new way. One problem I'm still having is with search. If I search using a term that's also a page name, I get a messed up URL like this (domain name is twice):

http://wiki.mydomain.com/http://wiki.mydomain.com/index.php?title=Automobile

I'd be curious if you have the same problem.

Jonathan3 (talkcontribs)

I think the answer to the original question is Yes. Your website probably won't fully work until you have completed the upgrade process, but it's normal to have to ensure skins and extensions are compatible with the new version.

151.165.212.150 (talkcontribs)

Thanks for the help.

151.165.212.150 (talkcontribs)

Scott216

I think you misread my question maybe.

Reply to "WikiMedia and PHP Upgrade"