Topic on Talk:Content translation

Jump to navigation Jump to search

Unable to work on current translation, page keeps loading source article

This topic was hidden by 212.96.66.137
Reason: Because of some problems
16
Alvaro Vidal-Abarca (talkcontribs)

Hi everybody. I'm experiencing an issue with an ongoing translation I'm working at: (edit: by the way, I've also tried on test.wikipedia.org) The source article keeps on loading, but never ends. I've tried with several browsers: Chrome in a laptop, Chrome in a mobile phone, Edge and Safari.

(edit: the Chrome console states:

load.php?debug=false&lang=ca&modules=ext.visualEditor.core|jquery%2Coojs-ui-core%2Coojs-ui-widgets|oojs-ui.styles.icons-editing-advanced&skin=vector&version=0hngfs9:964 JQMIGRATE: Migrate is installed with logging active, version 3.0.1
VM104:709 This page is using the deprecated ResourceLoader module "jquery.throttle-debounce".
Please use OO.ui.throttle/debounce instead. See https://phabricator.wikimedia.org/T213426
(anonymous) @ VM104:709
load.php?debug=false&lang=ca&modules=ext.visualEditor.core|jquery%2Coojs-ui-core%2Coojs-ui-widgets|oojs-ui.styles.icons-editing-advanced&skin=vector&version=0hngfs9:874 jQuery.Deferred exception: Unexpected token u in JSON at position 0 SyntaxError: Unexpected token u in JSON at position 0
   at JSON.parse (<anonymous>)
   at Object.ve.dm.CXReferenceNode.static.toDataElement (<anonymous>:454:920)
   at VeDmConverter.ve.dm.Converter.createDataElements (https://ca.wikipedia.org/w/load.php?debug=false&lang=ca&modules=ext.visualEditor.core%7Cjquery%2Coojs-ui-core%2Coojs-ui-widgets%7Coojs-ui.styles.icons-editing-advanced&skin=vector&version=0hngfs9:237:513)
   at VeDmConverter.ve.dm.Converter.getDataFromDomSubtree (https://ca.wikipedia.org/w/load.php?debug=false&lang=ca&modules=ext.visualEditor.core%7Cjquery%2Coojs-ui-core%2Coojs-ui-widgets%7Coojs-ui.styles.icons-editing-advanced&skin=vector&version=0hngfs9:244:48)
   at VeDmConverter.ve.dm.Converter.getDataFromDomSubtree (https://ca.wikipedia.org/w/load.php?debug=false&lang=ca&modules=ext.visualEditor.core%7Cjquery%2Coojs-ui-core%2Coojs-ui-widgets%7Coojs-ui.styles.icons-editing-advanced&skin=vector&version=0hngfs9:247:112)
   at VeDmConverter.ve.dm.Converter.getDataFromDomSubtree (https://ca.wikipedia.org/w/load.php?debug=false&lang=ca&modules=ext.visualEditor.core%7Cjquery%2Coojs-ui-core%2Coojs-ui-widgets%7Coojs-ui.styles.icons-editing-advanced&skin=vector&version=0hngfs9:247:112)
   at VeDmConverter.ve.dm.Converter.getDataFromDomSubtree (https://ca.wikipedia.org/w/load.php?debug=false&lang=ca&modules=ext.visualEditor.core%7Cjquery%2Coojs-ui-core%2Coojs-ui-widgets%7Coojs-ui.styles.icons-editing-advanced&skin=vector&version=0hngfs9:247:112)
   at VeDmConverter.ve.dm.Converter.getModelFromDom (https://ca.wikipedia.org/w/load.php?debug=false&lang=ca&modules=ext.visualEditor.core%7Cjquery%2Coojs-ui-core%2Coojs-ui-widgets%7Coojs-ui.styles.icons-editing-advanced&skin=vector&version=0hngfs9:238:771)
   at new MwCxDmTranslation (<anonymous>:90:1372)
   at MwCXInitTranslation.<anonymous> (<anonymous>:837:83) undefined
jQuery.Deferred.exceptionHook @ load.php?debug=false&lang=ca&modules=ext.visualEditor.core|jquery%2Coojs-ui-core%2Coojs-ui-widgets|oojs-ui.styles.icons-editing-advanced&skin=vector&version=0hngfs9:874
The resource https://ca.wikipedia.org/static/images/project-logos/cawiki.png was preloaded using link preload but not used within a few seconds from the window's load event. Please make sure it has an appropriate `as` value and it is preloaded intentionally.

)

Any help will be appreciated. Kind regards, Álvaro

Virageditor (talkcontribs)

Mine suffers from the the same problem. :/

Abad Works (talkcontribs)

Same problem.

ParticipantOfTheEncyclopedia (talkcontribs)

Same. My translation is Alienation (video game), EN - RU. I have translated the start of article and decided to stop translating for now. Later I opened the translation. However, it still says: "Загрузка Alienation (video game)", "загрузка" means "loading". I can't translate.

Also i have noticed one interesting thing. I have opened the "Angry Birds Epic" article that I translated earlier. It worked correctly. But the "Alienation" isn't working well.

Lzcjames (talkcontribs)

same problem

Wladek92 (talkcontribs)

I just open the link https://ca.wikipedia.org/wiki/Special:ContentTranslation?page=Affine+group&from=en&to=ca&targettitle=Grup+af%C3%AD and translate EN -> FR in the editor and seen NO problem. Article is correct. May be you have to retry now.

In mathematics, the affine group or general affine group of any affine space over a field K is the group of all invertible affine transformations from the space into itself.

It is a Lie group if K is the real or complex field or quaternions.

Relation to general linear group....

Poincaré group The Poincaré group is the affine group of the Lorentz group This example is very important in relativity. See also Holomorph References Roger Lyndon (1985) Groups and Geometry, Section VI.1, Cambridge University Press,

Wladek92 (talkcontribs)

I have reopened the few translations Ive done on Affine FR and I load my work successfully (last Firefox version on Vista Familial) . Of course the work you have done must be more consequent. Try other test translations to see if it is linked with your specific page or not, linked with the nature of the contents or not ...

Alvaro Vidal-Abarca (talkcontribs)

Well, it seems it has no relationship with the internet browser. I've just downloaded and installed Firefox from scratch, and the issue arises again. The problem arises only with ongoing translations, not with published ones. Plus, the error that I reported above ("SyntaxError: Unexpected token u in JSON at position 0") only appears with ongoing translations, not with completed ones.

Any idea regarding this approach?

Best regards,

Álvaro

Alvaro Vidal-Abarca (talkcontribs)

Hi @Wladek92:, thanks for your response. Still, I keep experiencing the same issue as reported before, specifically when trying to retrieve two on-going translations (namely, "Affine group" and "Group extension". The former is 88% translated and I'd like to preserve all the work done, if possible.

Anybody else is having this problem when editing an ongoing translation? Is there a way to publish or get the source code of an on-going translation (in the target language)?

Many thanks for your help. Kind regards,

Álvaro

Mylhaine C. (talkcontribs)

I have the same problem (I think) ; "Loading the saved translation..." is still runing, without end. I worked on "1st United States Sharpshooters" EN->FR. Think I have to Discard the translation :(

Thanks

Mylhaine C.

Wladek92 (talkcontribs)
Alvaro Vidal-Abarca (talkcontribs)

Thank you so much for your cooperation and help, @Wladek92:, I'll follow the thread at Phabricator to track how it evolves.

Regards!

Virageditor (talkcontribs)

Hi everyone!

I'd just like to note that after I had discarded my previous, eternally loading translation, started a new one. Everything went well until I wrote about a paragraph or more. So with some sentences, the page could be reopened, but when I worked more on the article, the same problem showed up.

I don't know if this information is useful, but I thought I would write it down.

Thank you,

Virág

LucaCaste (talkcontribs)

I'm having the same problem with a long translation. I had this problem once, and i resolved it deleting my full translation and doing it again, but this time I would try to get all back, because I've already traslated almost all. Did you find out a solution?

Thanks,

Luca

Pginer-WMF (talkcontribs)

These issues are not always easy to reproduce, but we'll investigate further. From the comments it seems that the issue is more likely to happen when trying to restore longer translations, but I wonder if the problem may be related to the size of the translation, some particular type of content/template that the tool is not handling properly, or the possibility that the source article may have changed meanwhile which can cause some problems we are already planning to solve.

In any case, the examples provided should be useful for further investigation and we'll be looking into the specific ticket. Please feel free to share any additional details that can help to reproduce the issue.

thanks!

Lzcjames (talkcontribs)

My translation in progress is "sopra steria" from FR to ZH and it has been 16% in progress, I think the size of the translation may not be related with the problem.