Topic on Project:Support desk

Jump to navigation Jump to search
2003:DE:AF23:6100:4164:2072:556B:5ED8 (talkcontribs)

I am using Media Wiki 1.32.1. I would like to include a video in mp4 format.

Can someone tell me which extension I need?

What are your experiences?

Victwana (talkcontribs)

My experience is very limited as it been few days ago I've been using or joined Wikipedia.

AhmadF.Cheema (talkcontribs)
2003:DE:AF23:6100:84CB:6414:DFA1:A917 (talkcontribs)

Thank you for the tip. But when I add the extension to the localSettings.php

wfLoadExtension( 'TimedMediaHandler' );

I can't reach my side anymore. The wiki website is then white.

AhmadF.Cheema (talkcontribs)
2003:DE:AF23:6100:E0C8:4FCE:B5BB:E074 (talkcontribs)

Can somebody give me a hint on what I can do?

Would like to use the TimedMediaHandler extension.

I get the following message in my browser:

Uncaught Exception: /var/www/vhosts/hosting.netcup.net/httpdocs/wiki/extensions/TimedMediaHandler/extension.json does not exist! in /var/www/vhosts/hosting.netcup.net/httpdocs/wiki/includes/registration/ExtensionRegistry.php:107 Stack trace: #0 /var/www/vhosts/hostingnetcup.net/httpdocs/wiki/includes/GlobalFunctions.php(50): ExtensionRegistry->queue('/var/www/vhosts...') #1 /var/www

Malyacko (talkcontribs)

You could post version information for TimedMediaHandler and you could post a complete stacktrace (your last post is just a small part of the stacktrace) with line breaks.

2003:DE:AF23:6100:E0C8:4FCE:B5BB:E074 (talkcontribs)

Sorry about that. Here is the complete message

Fatal error: Uncaught Exception: /var/www/vhosts/hosting.netcup.net/httpdocs/wiki/extensions/TimedMediaHandler/extension.json does not exist! in /var/www/vhosts/hosting.netcup.net/httpdocs/wiki/includes/registration/ExtensionRegistry.php:107 Stack trace: #0 /var/www/vhosts/hosting.netcup.net/httpdocs/wiki/includes/GlobalFunctions.php(50): ExtensionRegistry->queue('/var/www/vhosts...') #1 /var/www/vhosts/hosting.netcup.net/httpdocs/wiki/LocalSettings.php(149): wfLoadExtension('TimedMediaHandl...') #2 /var/www/vhosts/hosting.netcup.net/httpdocs/wiki/includes/Setup.php(103): require_once('/var/www/vhosts...') #3 /var/www/vhosts/hosting.netcup.net/httpdocs/wiki/includes/WebStart.php(77): require_once('/var/www/vhosts...') #4 /var/www/vhosts/hosting.netcup.net/httpdocs/wiki/index.php(39): require('/var/www/vhosts...') #5 {main} thrown in /var/www/vhosts/hosting.netcup.net/httpdocs/wiki/includes/registration/ExtensionRegistry.php on line 107

Malyacko (talkcontribs)

My previous comment asked for version information for TimedMediaHandler and a complete stacktrace (having every line end in "..." is not a complete stacktrace), but anyway: /var/www/vhosts/hosting.netcup.net/httpdocs/wiki/extensions/TimedMediaHandler/extension.json does not exist!

So you have to find out why it does not exist. And explain how exactly you install TimedMediaHandler.

AhmadF.Cheema (talkcontribs)

From where exactly did you download the Extension:TimedMediaHandler files (or maybe you didn't)?

What is the version of your MediaWiki?

Can you provide a link to your Wiki?

2003:DE:AF23:6100:E0C8:4FCE:B5BB:E074 (talkcontribs)

During the installation of the TimedMediaHandler in the LocalSettings.php the directory wiki/extensions/

the TimedMediaHandler extension or folder is not created.

2003:DE:AF23:6100:E0C8:4FCE:B5BB:E074 (talkcontribs)

I defined the extension in Localsettings.php as follows: wfLoadExtension( 'TimedMediaHandler' );

The version of the Media Wiki is 1.32.1

Corraggiouno (talkcontribs)
AhmadF.Cheema (talkcontribs)

Have you followed this step:

  • Download and place the file(s) in a directory called TimedMediaHandler in your extensions/ folder.
Corraggiouno (talkcontribs)

Okay, that worked. Great. The Wiki page is available again. I also did an update. What I unfortunately noticed. If I want to upload a video (about 20 MB) mp4, then I get the following message: [55fbb821de0d3c8f870f2623] 2019-05-23 14:30:20: Fatal exception error of type "Error 

AhmadF.Cheema (talkcontribs)

For the "Fatal exception error", in your LocalSettings.php, set:

$wgShowExceptionDetails = true;

$wgDevelopmentWarnings = true; error_reporting( -1 ); ini_set( 'display_errors', 1); error_reporting(E_ALL);

and then perform the same actions which led to the fatal error. This should provide a more detailed error description.

Corraggiouno (talkcontribs)

Thank you so much for your help. This is my output:

/wiki/extensions/TimedMediaHandler/includes/handlers/Mp4Handler/Mp4Handler.php(12): ID3Handler->getID3(string)

/httpdocs/wiki/extensions/TimedMediaHandler/includes/handlers/ID3Handler/ID3Handler.php(51): Mp4Handler->getID3(string)

t/httpdocs/wiki/includes/utils/MWFileProps.php(84): ID3Handler->getMetadata(FSFile, string)

httpdocs/wiki/includes/upload/UploadBase.php(509): MWFileProps->getPropsFromPath(string, string)

httpdocs/wiki/includes/upload/UploadBase.php(444): UploadBase->verifyPartialFile()

httpdocs/wiki/includes/upload/UploadBase.php(347): UploadBase->verifyFile()

httpdocs/wiki/includes/upload/UploadFromFile.php(95): UploadBase->verifyUpload()

/httpdocs/wiki/includes/specials/SpecialUpload.php(503): UploadFromFile->verifyUpload()

httpdocs/wiki/includes/specials/SpecialUpload.php(207): SpecialUpload->processUpload()

httpdocs/wiki/includes/specialpage/SpecialPage.php(569): SpecialUpload->execute(NULL)

/wiki/includes/specialpage/SpecialPageFactory.php(568): SpecialPage->run(NULL)

/wiki/includes/MediaWiki.php(288): MediaWiki\Special\SpecialPageFactory->executePath(Title, RequestContext)

/httpdocs/wiki/includes/MediaWiki.php(860): MediaWiki->performRequest()

t/httpdocs/wiki/includes/MediaWiki.php(517): MediaWiki->main()

/wiki/index.php(42): MediaWiki->run()

#15 {main}

Ciencia Al Poder (talkcontribs)

That's the stack trace but not the error message. The extension may be missing the id3 library, that you need to get with composer.

Inside the TimedMediaHandler extension directory, run:

composer install --no-dev
Corraggiouno (talkcontribs)

I don't have SSH access. But I have the alternative via

{

   "extra": {

       "merge-plugin": {

           "include": [

               "extensions/TimedMediaHandler/composer.json"

           ]

       }

   }

}

Added to the DAtei composer.json. Unfortunately I still get the error message

extensions/TimedMediaHandler/includes/handlers/ID3Handler/ID3Handler.php: Class 'getID3' not found

Ciencia Al Poder (talkcontribs)

Without running composer, adding that line won't do anything...

You can download the TimedMediaHandler folder to your PC, run composer locally to get the id3 library, and upload it again to the server

Corraggiouno (talkcontribs)

Thank you. What else do I need (I have a PC with Windows) so that I can even use the command

composer install --no-dev

can execute?

Malyacko (talkcontribs)
Corraggiouno (talkcontribs)

Hi. I did the composer installation locally and that worked so far.

Loading composer repositories with package information

Updating dependencies

Package operations: 1 installation, 0 updates, 0 distances, 0 distances

  - Installing james-heinrich/getid3 (v1.9.17): Download (100%)

Writing a lock file

Creating autoload files

Then I uploaded the folder TimedMediaHandler again. Unfortunately I still get the following error message:

Warning: require(/var/wwww/vhosts/hosting.netcup.net/httpdocs/wiki/includes/filebackd/FileBackendGroup.php): Stream could not be opened: No such file or directory in /var/wwww/vhosts/hosting.netcup.net/httpdocs/wiki/includes/AutoLoader.php on line 109

Warning: require(/var/wwww/vhosts/hosting.netcup.net/httpdocs/wiki/includes/filebackd/FileBackendGroup.php): Stream could not be opened: No such file or directory in /var/wwww/vhosts/hosting.netcup.net/httpdocs/wiki/includes/AutoLoader.php on line 109

Serious error: require(): Failed opening required '/var/wwww/vhosts/hosting.netcup.net/httpdocs/wiki/includes/filebackend/FileBackendGroup.php' (include_path='/var/wwww/vhosts/hosting.netcup.net/httpdocs/wiki/vendor/pear/console_getopt:/var/www/vhosts/hosting.netcup.net/httpdocs/wiki/vendor/pear/mail:/var/www/vhosting.netcup.net/httpdocs/wiki/vendor/pear/mail_mime:/var/www/vhosts/hosting.netcup.net/httpdocs/wiki/vendor/pear/net_smtp:/var/wwww/vhosts/hosting.netcup.net/httpdocs/wiki/vendor/pear/net_socket:/var/www/hosting.netcup.net/httpdocs/wiki/vendor/pear/pear/pear-core-minimal/src:/var/www/vhosts/hosting.netcup.net/httpdocs/wiki/vendor/pear/pear/pear/pear_exception:.:/opt/plesk/php/7.2/share/pear') in /var/www/vhosts/hosting.netcup.net/httpdocs/wiki/includes/AutoLoader.php on line 109

Corraggiouno (talkcontribs)

I just looked on the server (ftp) and the folder "filebackend" is missing.

What can I do to get this folder back and that the error message from above is no longer displayed?

Ciencia Al Poder (talkcontribs)

The file and folder are there on MediaWiki 1.32: includes/filebackend/FileBackendGroup.php.

Either you removed a folder in error, or there's some suspicious activity on your server that's deleting random folders...

I'd download MediaWiki 1.32 again from the official repositories and replace all the files with that.

Reply to "Video extension"