Topic on Extension talk:VisualEditor

Jump to navigation Jump to search
Tansaku (talkcontribs)

We just upgraded to mediawiki 1.32. We have visual editor working fine with mediawiki 1.31, but with 1.32 the visual editor fails to even start loading and has this warning/error in the js console in the browser:

> VisualEditor failed to load: Error: One or more dependencies failed to load

Has anyone else experienced similar?

More details here: https://github.com/AgileVentures/SocialPrescribingWiki/issues/76

Ryanjjjj (talkcontribs)

Bump, pretty frustrating...

Bovender (talkcontribs)

Same problem here. MW 1.32 (Docker image), linking to a Parsoid service that is also running in a Docker container (and is up and running).

Bozomal (talkcontribs)
Dstoeltz (talkcontribs)

I fought with this issue for a while and ended up going through and disabling all of my extensions one-by-one. In my case it was the UserPageViewTracker extension that was causing this error somehow. As soon as I disabled it, this error was resolved.

205.200.97.2 (talkcontribs)

Have similar issue. Mine seems to be linked to Chameleon skin

Bovender (talkcontribs)

I have now upgraded to MW 1.34, updated the VisualEditor extension, and it works! Using the Chameleon skin, btw.

Reply to "Mediawiki 1.32"