Topic on Talk:Phabricator/Help

Jump to navigation Jump to search
Alex brollo (talkcontribs)

I can'l login into Phabricator with my user name Alex_brollo, login form replaces underscore with a space then it complains for an incorrect user name (of course....). When I try to login by mediawiki account, login form complaints about tha fact that an user exists using the same email (of course...).

How can I login?


AKlapper (WMF) (talkcontribs)

Login form for LDAP does not replace underscore with a space here (Firefox 64).

After which exact last steps does this happen? With which exact browser? Does that also happen with another browser?

BrolloBot (talkcontribs)

I'm using Maxthor, a light browse running in an old PC with Windows XP (the modern died suddenly, I'm waiting for its resuscitation..); I'll try with Chrome or Firefox, but both aren't happy to run under XP. Let's try.....

Alex brollo (talkcontribs)

Try with Chrome failed, I asked for a new password, no success.... Strangely, in cnfirmation mail my user name is defined as "Alex brollo", while it is "Alex_brollo". Many years ago, when I registered my MediaWiki user name (Alex brollo), I didn't know that a space into an username is a bad idea....

(PS: obviously BrolloBot is another my username for my bot account, I tried to login with it too with no success).


AKlapper (WMF) (talkcontribs)

"asked for a new password" where and how exactly? What does "no success" mean? No email received, or email received and password entered (on which website) but some error (which one?) on Phabricator?

Please be clear and exact. Thanks!

Alex brollo (talkcontribs)

I apologyze.

New try using Firefox, after central login with my main user name Alex brollo.

As I click on the left button "Login or Register Mediawiki", at https://phabricator.wikimedia.org/auth/start/?next=%2FT209939, an OAuth popup opens; I click on "Allow" button; a page "Create new account" opens, user name "Alex_brollo", when I try to fill required fields (email) and click "Register" the page tells that both user name and email are duplicated.


Then I tried to ask a new password for LDAP user Alex_brollo and I got a mail from Wikitech, with a temporary password for user "Alex brollo" (no underscore!):

"The following user account is associated with this email address:

Username: Alex brollo

Temporary password: " (follows a password)

I tried LDAP login with that username (both with space and with underscore) and the new password: both username and password are "Invalid".


I'm sure that previusly I contrbuted to Phabricator by mediawiki login with no problem; presently I'm so confused (and frustrated!) that I can't remember if I have, or I have not, a LDAP account.


AKlapper (WMF) (talkcontribs)

You cannot have been active in Phabricator by mediawiki login before because you have not attached your MediaWiki user account to your Phabricator account - see https://phabricator.wikimedia.org/p/Alex_brollo/. So your only option is LDAP/wikitech login.

As you received a temporary password, did you log in on wikitech.wikimedia.org with that temporary password to set a non-temporary password before trying that password on Phabricator?

Alex brollo (talkcontribs)

Ok. I successfully log in into wikitech.wikimedia.org with temporary password, then I set a new password, ok, then I successfully log in into Phabricator using the new password. Thanks for your time and for your help.

Anthony Appleyard (talkcontribs)

My Wikipedia username, and many other Wikipedia users' usernames, also contain a space which sometimes morphs into an underline.