Topic on Help talk:Extension:AdvancedSearch

Jump to navigation Jump to search

Issue: Exact this search does not match exact string

5
197.218.80.183 (talkcontribs)

Issue:

Searching for "exact this text" doesn't find only the exact string

Steps to reproduce:

  1. Search for "brand of popcorn in North America" -> https://en.wikipedia.org/w/index.php?search=%22brand+of+popcorn+in+North+America%22&title=Special%3ASearch&profile=default&fulltext=1
  2. Search it using advanced search : https://en.wikipedia.org/w/index.php?search=brand+of+popcorn+in+North+America&title=Special%3ASearch&profile=advanced&fulltext=1&advancedSearch-current=%7B%22options%22%3A%7B%22phrase%22%3A%22brand+of+popcorn+in+North+America%22%7D%2C%22namespaces%22%3A%5B0%2C6%5D%7D&ns0=1&ns6=1

Expected

Step 2 above matches step 1, e.g. it only finds words that exactly contain "brand of popcorn in North America". Exactly in that order.

Actual

It currently also finds strings like:

Popcorn (popped corn, popcorns or pop-corn) is a variety of corn kernel, which expands and puffs up when heated. A popcorn kernel's strong hull contains

https://en.wikipedia.org/w/index.php?title=Popcorn&oldid=870872258

Proposed solution:

  1. Either make the "exact text" match the string exactly with no further words, e.g. step 1 above;
  2. Or create a separate input box for an "exact match" if it is working as expected.
197.218.80.183 (talkcontribs)

Basically it seems to be doing an OR search, e.g. "brand" OR "of" OR "popcorn" OR "in" OR "North America", which is unexpected.

197.218.80.183 (talkcontribs)

Hmm, just noticed that the tooltip help claims that it must always have quotations marks. This makes no sense whatsoever. If the user has to add quotation marks, then they can just type directly in the main search box, rather than use "advanced search".

Having also tried the suggested syntax, it also doesn't seem remotely sensible, https://en.wikipedia.org/w/index.php?search=%22brand+of+popcorn%22%2C%22in+North+America%22&title=Special:Search&profile=advanced&fulltext=1&advancedSearch-current=%7B%22options%22%3A%7B%22phrase%22%3A%22%5C%22brand+of+popcorn%5C%22%2C%5C%22in+North+America%5C%22%22%7D%2C%22namespaces%22%3A%5B0%2C6%5D%7D&ns0=1&ns6=1 .

It finds the page https://en.wikipedia.org/wiki/Comma, probably because the search string contains a comma.

TheDJ (talkcontribs)

I agree that this seems unintuitive

Michael Schönitzer (WMDE) (talkcontribs)

Hey, thanks to both of you for your input! The usability of this field turned out to be more tricky than one might think. Our tests confirm that while the current version works better than previous attempts it still is not very intuitive. So we are aware that it's still not great yet. There's also a ticket about this.

Reply to "Issue: Exact this search does not match exact string"