Topic on Talk:Parsing

Jump to navigation Jump to search

Parser problem? ticket in phabricator.

4
Summary by SSastry (WMF)
Herzi Pinki (talkcontribs)

Hi folks, I come here because of https://phabricator.wikimedia.org/T209236 (and because AKlapper recommended it) I guessed that this issue should be assigned to the MediaWiki-Parser, but I might be wrong. Can you please have a look at the ticket and assign a priority to it. If my guess is wrong, please move it to the right project. best --Herzi Pinki (talk) 18:49, 23 November 2018 (UTC)

197.235.56.207 (talkcontribs)

Seems like a recent change caused this, searching phabricator keywords, the most likely cause is :https://phabricator.wikimedia.org/T206940.

Until it is fixed or reverted, it is easy to manually fix these links, especially if they are being generated by a template, simply switch the param around so replace this:

[[File:Erioll world.svg|15px|alt=Welt-Icon|link=//tools.wmflabs.org/geohack/geohack.php?pagename=Hirtenberg&language=de¶ms=47_N_16_E]]


With this:

[[File:Erioll world.svg|15px|alt=Welt-Icon|link=//tools.wmflabs.org/geohack/geohack.php?params=47_N_16_E&pagename=Hirtenberg&language=de]]

The link below should be working: Welt-Icon

Herzi Pinki (talkcontribs)

facepalm. Thanks for the hint. Workaround works like a charm. The issue is still open. --Herzi Pinki (talk) 21:06, 23 November 2018 (UTC)

SSastry (WMF) (talkcontribs)

Thanks for flagging it and filing the phab task. And thanks anonymous for the workaround. Since this is being tracked in Phabrication, I am going to close the discussion here so we track it one place.