Topic on Project:Support desk

Jump to navigation Jump to search
195.162.12.14 (talkcontribs)

Hi

I am trying to move my wiki to a new laptop. I have loaded MAMP 4.5 and midiawiki 1.31. I have configured in the same way as I have always done in the past and I have the default page showing.

used php dumpBackup.php --full > filename to dump my old pages.. All OK

however when I try to import on my new system I get this

phil@M-C02VD1YAG8WN: php importDump.php  wikidump

[1e5b569077b3bdcc708accfd] [no req]   Wikimedia\Rdbms\DBConnectionError from line 1004 of /Users/phil/philbwiki/includes/libs/rdbms/database/Database.php: Cannot access the database: No such file or directory (localhost)

Backtrace:

#0 /Users/phil/philbwiki/includes/libs/rdbms/loadbalancer/LoadBalancer.php(1134): Wikimedia\Rdbms\Database->reportConnectionError(string)

#1 /Users/phil/philbwiki/includes/libs/rdbms/loadbalancer/LoadBalancer.php(749): Wikimedia\Rdbms\LoadBalancer->reportConnectionError()

#2 /Users/phil/philbwiki/includes/GlobalFunctions.php(2801): Wikimedia\Rdbms\LoadBalancer->getConnection(integer, array, boolean)

#3 /Users/phil/philbwiki/includes/cache/localisation/LCStoreDB.php(45): wfGetDB(integer)

#4 /Users/phil/philbwiki/includes/cache/localisation/LocalisationCache.php(412): LCStoreDB->get(string, string)

#5 /Users/phil/philbwiki/includes/cache/localisation/LocalisationCache.php(458): LocalisationCache->isExpired(string)

#6 /Users/phil/philbwiki/includes/cache/localisation/LocalisationCache.php(334): LocalisationCache->initLanguage(string)

#7 /Users/phil/philbwiki/includes/cache/localisation/LocalisationCache.php(271): LocalisationCache->loadItem(string, string)

#8 /Users/phil/philbwiki/languages/Language.php(600): LocalisationCache->getItem(string, string)

#9 /Users/phil/philbwiki/includes/title/MediaWikiTitleCodec.php(85): Language->needsGenderDistinction()

#10 /Users/phil/philbwiki/includes/title/MediaWikiTitleCodec.php(214): MediaWikiTitleCodec->getNamespaceName(integer, string)

#11 /Users/phil/philbwiki/includes/cache/LinkCache.php(234): MediaWikiTitleCodec->getPrefixedDBkey(Title)

#12 /Users/phil/philbwiki/includes/Title.php(3449): LinkCache->addLinkObj(Title)

#13 /Users/phil/philbwiki/includes/Title.php(3229): Title->getArticleID()

#14 /Users/phil/philbwiki/includes/Title.php(3093): Title->loadRestrictions()

#15 /Users/phil/philbwiki/includes/Title.php(2389): Title->getRestrictions(string)

#16 /Users/phil/philbwiki/includes/Title.php(2737): Title->checkPageRestrictions(string, User, array, string, boolean)

#17 /Users/phil/philbwiki/includes/Title.php(2114): Title->getUserPermissionsErrorsInternal(string, User, string, boolean)

#18 /Users/phil/philbwiki/includes/import/WikiImporter.php(1108): Title->userCan(string)

#19 /Users/phil/philbwiki/includes/import/WikiImporter.php(787): WikiImporter->processTitle(string, string)

#20 /Users/phil/philbwiki/includes/import/WikiImporter.php(608): WikiImporter->handlePage()

#21 /Users/phil/philbwiki/maintenance/importDump.php(345): WikiImporter->doImport()

#22 /Users/phil/philbwiki/maintenance/importDump.php(278): BackupReader->importFromHandle(resource)

#23 /Users/phil/philbwiki/maintenance/importDump.php(114): BackupReader->importFromFile(string)

#24 /Users/phil/philbwiki/maintenance/doMaintenance.php(94): BackupReader->execute()

#25 /Users/phil/philbwiki/maintenance/importDump.php(350): require_once(string)

#26 {main}

I get the same sort of message if I try to dump from my new installation.

phil@M-C02VD1YAG8WN:  php dumpBackup.php --full > pp

[a626cc63c3c486b8a1715410] [no req]   Wikimedia\Rdbms\DBConnectionError from line 1004 of /Users/phil/philbwiki/includes/libs/rdbms/database/Database.php: Cannot access the database: No such file or directory (localhost)

Backtrace:

#0 /Users/phil/philbwiki/includes/libs/rdbms/loadbalancer/LoadBalancer.php(1134): Wikimedia\Rdbms\Database->reportConnectionError(string)

#1 /Users/phil/philbwiki/includes/libs/rdbms/loadbalancer/LoadBalancer.php(749): Wikimedia\Rdbms\LoadBalancer->reportConnectionError()

#2 /Users/phil/philbwiki/includes/GlobalFunctions.php(2801): Wikimedia\Rdbms\LoadBalancer->getConnection(integer, array, boolean)

#3 /Users/phil/philbwiki/maintenance/backup.inc(308): wfGetDB(integer)

#4 /Users/phil/philbwiki/maintenance/backup.inc(255): BackupDumper->initProgress(integer)

#5 /Users/phil/philbwiki/maintenance/dumpBackup.php(80): BackupDumper->dump(integer, integer)

#6 /Users/phil/philbwiki/maintenance/doMaintenance.php(94): DumpBackup->execute()

#7 /Users/phil/philbwiki/maintenance/dumpBackup.php(137): require_once(string)

#8 {main}

as far as I can tell the LocalSettings.php is set up OK the database name and logins are all OK I have reset the password on the login and tried again but I cannot get past this error

Please do you have any suggestions

Thanks

Phil

Philbgt4 (talkcontribs)

for clarity the old version was using MAMP 3.4 and Media wiki 1.26.

I have set up the new versions exactly the same but cannot connect to the database.

Philbgt4 (talkcontribs)

I think I may have solved this changed

#$wgDBserver = "localhost";

to

$wgDBserver = "localhost:/Applications/MAMP/tmp/mysql/mysql.sock";

in LocalSettings.php

Reply to "cannot backup or restore"