Topic on Extension talk:Scribunto

Jump to navigation Jump to search

chcon: can't apply partial context to unlabeled file ‘lua’

AndyPKU (talkcontribs)

When I follow the manual instruction, and did "chcon -t httpd_sys_script_exec_t /path/to/extensions/Scribunto/engines/LuaStandalone/binaries/yourOS/lua" this, it sais that can't aplly partial context to unlabeled file 'lua'. What should I do?

Dinoguy1000 (talkcontribs)

Did you change the system path as appropriate for your environment? The path shown on the page is only a sample and won't work verbatim unless you intentionally set up your server with that directory structure. Specifically, the /path/to/extensions refers to the /extensions directory in MediaWiki's base directory; on a default server this might therefore be /var/www/html/extensions. Additionally, the /yourOS directory is just an example and needs to be replaced as appropriate; check what directories are contained in /extensions/Scribunto/engines/LuaStandalone/binaries and select the correct one for the operating system your server is running.

AndyPKU (talkcontribs)

in fact, my lua is in the path /var/www/html/extension/Scribunto/engines/LuaStandalone/binaries/lua5_1_5_linux_64_generic,and I use the command CD into this directory and use command as chcon -t httpd_sys_script_exec_t lua, I am not sure whether it is suitable, but I take it for grunted.. (talkcontribs)

Same issue here.

Trying with chcon -t httpd_sys_script_exec_t /var/www/mediawiki/extensions/Scributon/engines/LuaStandalone/binaries/lua5_1_5_linux_32_generic/lua sends the same error my way.

I am trying to setup my wiki using a Raspberry Pi 3, using 32-bit Raspbian. (talkcontribs)

Have anybody resolved this problem? What was the reason? (talkcontribs)

same problem here, tried running using just lua (from inside the 1_5_* folder) as well as using proper paths (talkcontribs)

Is anyone gonna address this issue?! (talkcontribs)

same issue here

2A01:C22:D486:E400:4162:A4C6:966A:F24B (talkcontribs)

same issue. Any ideas? Someone?

SheldonBole (talkcontribs)

I also had this error, however I went and re-read the manual instructions. Properly this time lol.

It says "if you are using SELinux in 'Enforicing' mode on your server, you might need to set a proper context". It then gives the example of chcon -t httpd_sys_script_exec_t.

To check if you are using SELinux check it's status by running "getenforce" this will return Enforced, Permissive, or Disabled. Or in my case:

"Command 'getenforce' not found, but can be installed with: apt install selinux-utils"

I therefore assumed it was not necessary, in my case, to run chcon -t httpd_sys_script_exec_t.

I however, am still not able to get Scribunto to work properly...

Reply to "chcon: can't apply partial context to unlabeled file ‘lua’"