Topic on 2017 wikitext editor/Feedback

Jump to navigation Jump to search

Undo's and popup reverts don't work

6
Summary last edited by Elitre (WMF) 16:16, 1 March 2018 8 months ago
Some Gadget Geek (talkcontribs)

Hello everyone!

One of the things I do a lot on Wikipedia is reverting edits, either because it is vandalism/disruptive or the revision before was better, etc. Although I have both rollback and Twinkle, I also use the revert tool in the popups and the undo link that everybody has access to, generally if I want to undo one or two particular changes while keeping others. However, with the 2017 wikitext editor I find that neither undo nor popup reverts work as they did before. Could anyone investigate and consider repairing this flaw soon?

Many thanks,

SGG

Elitre (WMF) (talkcontribs)

Hi! Your username looks very relevant here :) If you're talking about this tool, you need to investigate with its maintainers about why it may not be working as you'd expect. I am not sure about the undo links - a simple revert to last edition seems to work fine to me, but most importantly I believe that its interface is actually the same than the 2010 wikitext editor one, so if there's a problem there it's not due to the newest editor?

Some Gadget Geek (talkcontribs)

Hi Elitre,

The undo function actually brings me back to the 2010 editing box, as you stated. But besides this, there seems to be no other way to access the old window. If I, say, go to an old revision of a page (for example, this instance in which a user blanked an article page) and click "edit" there (expecting to see an empty editor without any content), the 2017 editor loads the current revision, which is not what I expect. So it can't possibly have to do with just the popups, although I did post in that talk page (Wikipedia talk:Tools/Navigation popups). I do really like the 2017 editing UI and don't want to be forced back to the 2010 UI so I hope someone can look into this problem soon.

Best,

SGG

Whatamidoing (WMF) (talkcontribs)

SGG, I think you've found a VisualEditor/Single edit tab problem with the blank page/wrong revision. Can you please go to w:en:Special:Preferences#mw-prefsection-editing and tell me what your "Editing mode" is? For example, mine is set to "Show me both tabs".

By the way, if you ever need to open a page in the 2010 WikiEditor, then you can hand-edit the URL to say &action=submit (rather than &action=edit ).

Some Gadget Geek (talkcontribs)

Mine's is set to "show me both tabs" as well. Although at first I did not use the Visual Editor much, it has improved to the extent that I am now using it as much as the old editor. But there are still a couple of things that I get done using the old editor faster (especially making wiki-links), so it's highly unlikely that I will change my editing mode setting in the near future.

Whatamidoing (WMF) (talkcontribs)

Thanks. I think I've figured out where that &action=edit was coming from. Perhaps that's part of the problem.

Reply to "Undo's and popup reverts don't work"