Topic on Project:Support desk

Jump to: navigation, search

*All* pages give a Permission Error after upgrading

7
DaVince21 (talkcontribs)

I upgraded to 1.28.2 recently, but now I have found that my wiki will not display any page to visitors. It will just display a Permission Error instead.

The wiki can be found here: http://wiki.spheredev.org/Main_Page

It shows this error for all pages, including the login page. Luckily my session was somehow kept between upgrades, so I can confirm that all pages do display properly when I'm logged in.

Also: the previous version of the wiki ran on (really too many) extensions, but I tried configuring at least a few of the most important ones. Two enabled plugins are ConfirmAccount and ConfirmEdit, but I don't know if those are related at all.

AhmadF.Cheema (talkcontribs)

ConfirmEdit and ConfirmAccount should not be the issue here.

See if your LocalSettings.php file has the following line or not

$wgGroupPermissions['*']['read'] = false;

Also, try adding the following line:

$wgWhitelistRead = array ("Special:Userlogin");

This should allow the Wiki login page to become accessible.

DaVince21 (talkcontribs)

Thanks. Group permissions seemed to be fine, I even explicitly set that to true and it's still doing it. It's also ignoring the whitelist entirely.

Ciencia Al Poder (talkcontribs)

According to api, group permissions for "*" includes read rights, so it should work... I don't know what may be the cause, though. You can try disabling all extensions and see if the problem disappears, then enable them one by one until you find the cause.

2601:8C:4500:7BFF:819C:BE10:F6D9:8B9E (talkcontribs)

The specific error our users are seeing when llogged out is:

You do not have permission to read this page, for the following reason: You must confirm your email address before editing pages. Please set and validate your email address through your user preferences.

This even happens for the login page, so it's impossible to even log in.

This comment was hidden by AhmadF.Cheema (history)
AhmadF.Cheema (talkcontribs)

Have you already tried the above suggestion of disabling all extensions and seeing if it changes anything?