Topic on Extension talk:WikiEditor

MW Rel 1.29.0 : bug report : Cancel button does not work properly

Spas.Z.Spasov (talkcontribs)

WikiEditor cancel button (upper right corner) redirects to uri /undefined. Here you are a screen shot.

Could it be fixed in the next release? (talkcontribs)

I see this on my site too. I have temporarily disabled the Publish/Cancel buttons on the upper right. The buttons at the bottom seem to be working just fine. (talkcontribs)

I am using MW 1.29.1, by the way. Still see the issue.

This post was hidden by Abhidevananda (history)
Abhidevananda (talkcontribs)

Though it's just a temporary and convenient precaution (not a solution), I've disabled just the not-working Cancel button... leaving the still-working Publish button in place... by editing the jquery.wikiEditor.publish.js file in the modules directory to delete (or comment out) the following code:

context.fn.addButton( {

    captionMsg: 'wikieditor-publish-button-cancel',

    action: function () {

        window.location.href = $( '#mw-editform-cancel' ).attr( 'href' );

        return false;


} );

NOTE: This is not a good solution for MW1.29 and MW1.29.1. A better solution is provided below. However, if the WikiEditor extension is not fixed to resolve this problem before the general release of MW1.30, then those with MW1.30 and onward may want to resort to this inadequate fix.

Abhidevananda (talkcontribs)

Problem solved for MW1.29.0 and MW1.29.1

The issue and the workaround are detailed in the MW1.29 release notes. A solution to the problem is found there and also here.

In short, all that you need to do is add the following code in LocalSettings.php.

$wgOOUIEditPage = false;

NOTE: This workaround will only help with the MW1.29 releases. From MW1.30 onward, we are stuck with the red Cancel button (as seen below any edit box on this page) instead of the blue Cancel button from earlier releases (that this fix takes us back to). So the developers of WikiEditor will have to make some change in the extension code to accommodate that. (talkcontribs)

Thanks a bunch, Abhidevananda and others. This worked for me.

Reply to "MW Rel 1.29.0 : bug report : Cancel button does not work properly"