Topic on Project:Support desk

Jump to navigation Jump to search

An error: Deprecated: Function mcrypt_create_iv() is deprecated

2
Little Qiu (talkcontribs)

(I'm a Chinese, I'm very sorry for my bad English.)

Hello everyone.

I installed MediaWiki on localhost, but it displays an error at the top of the page: Deprecated: Function mcrypt_create_iv() is deprecated in /.../html/mediawiki/includes/libs/CryptRand.php on line 256

I want to know how to solve this error. I use PHP 7.1.3 with mcrypt and MediaWiki 1.28.2.

Thank you!

Ciencia Al Poder (talkcontribs)

Reported in task T143788.

Deprecation warnings can be safely ignored, they're for development.

You can disable them by adding this to LocalSettings.php:

error_reporting(E_ERROR | E_WARNING | E_PARSE);