Topic on Talk:Editing team/Current priorities

Jump to navigation Jump to search
130.76.186.12 (talkcontribs)
Jdforrester (WMF) (talkcontribs)

Yes and no.

Wikimedia development policy is that users should use the appropriate branch. Thus, if you want to use MediaWiki 1.27, you should use VisualEditor REL1_27 which should work fine. The master branch shouldn't be unnecessarily backwards-compatible with old versions of code if it adds complexity or slowness. In general, VisualEditor master requires MediaWiki master and will break if you try to use it blindly with another version. You can try to back-port individual commits, but MediaWiki 1.27 stopped being actively developed in April/May 2016 and there have been 3100 patches to MediaWiki, and 1277 to VisualEditor, since then.

Also, note that LTS is about security patches, not features, and doesn't apply to non-core software (like VisualEditor) anyway.

Reply to "VisualEditor & MediaWiki Roadmap"