Topic on Talk:Content translation

Jump to navigation Jump to search
Summary by ねをなふみそね
  • Problems: CX doesn't work in JAWP. The pull down menu function that CX provides in the Vector Skin doesn't work well. The speed of loading a page is unusually slow. Browser in use and its version: Firefox 50.0.x. for desktop.
  • Solution: Stop using the exlink gadget.
  • Reason for the problems: Dependencies of the exlink gadget ?
223.135.105.201 (talkcontribs)

Greetings to developers. I enjoyed translations with CX in Japanese Wikipedia until a couple of days before, but now I cannot get start to run it. I don't get the reason but suddenly I have got not to enter the pages of CX. I purged a page, and I restarted my browser but CX didn't work. The browser I mainly use is firefox and its version is 50.0.2, the latest version. Probably this latest firefox prevents CX from working. I switched the browser to Google Chrome, then I could get CX started. If anyone among you guys can solve this problem, it would be helpful for me, and maybe for other firefox users.

Amire80 (talkcontribs)

Thanks for the report!

Can you please try enabling the web console under tools in your Firefox menu, then go to Content Translation and tell me whether you see any error messages?

ねをなふみそね (talkcontribs)

Now, I tried it and saw these two lines. "詳細" means "details". I hope this could be your help for fixing bugs.

Gadget "ReferenceTooltips" styles loaded twice. Migrate to type=general. See <https://phabricator.wikimedia.org/T42284>. %E3%81%AD%E3%82%92%E3%81%AA%E3%81%B5%E3%81%BF%E3%81%9D%E3%81%AD:800:45 TypeError: mw.util.$content is null[詳細] load.php:84:563

Amire80 (talkcontribs)
ねをなふみそね (talkcontribs)

Thanks for the suggestion on that page. I will notify you soon, when I encounter another problem or bug.

Amire80 (talkcontribs)

I see that the fixed that I suggested were made. Does it solve the problem?

ねをなふみそね (talkcontribs)
Amire80 (talkcontribs)

Hmm.

Can you please enable the JS console and go to Special:CX, and then check the console? This URL should enable more detailed error messages.

ねをなふみそね (talkcontribs)

I enabled it and went to there, and saw "TypeError: mw.util.$content is null"

My firefox outputs only the division that is tagged by "p-personal" without displaying the other portion of page.

I try en:Special:ContentTranslation since today for a while, maybe until firefox gets improvement about this bug.

Thanks a lot for your improving the configuration of the gadgets on JAWP.

Amire80 (talkcontribs)

Does it say anything more on the line with the error? For example, a line number or a file name?

Amire80 (talkcontribs)

Also, do you use the "exlinks" gadget (外部リンクを新しいウィンドウ・タブで開く) on the Japanese Wikipedia?

ねをなふみそね (talkcontribs)

Thanks for cooperating us, JAWP users.

  1. Yes, I use that gadget ( though I have not know that check box is configured to enable it. )
  2. I went to JAWP Special:CX for the first time, then I found the error described below on the web console of my firefox (50.0.0.2) for desktop iOS.
  3. Here' the error message. TypeError: mw.util.$content is null[詳細]  load.php:81:563 <匿名関数> https://ja.wikipedia.org/w/load.php:81:563 jQuery.Callbacks/fire https://ja.wikipedia.org/w/load.php:45:104 jQuery.Callbacks/self.fireWith https://ja.wikipedia.org/w/load.php:46:431 .ready https://ja.wikipedia.org/w/load.php:49:400 completed https://ja.wikipedia.org/w/load.php:49:925
  4. The message shown above is output when browsing any other JAWP pages including Special:watchlist, mainpage etc.
  5. The message isn't output when browsing ENWP pages.
  6. Today I went to Special:CX again, I don't find the message. Firefox's version is 50.0.2 for Windows 7. But, it is shown in other pages of JAWP.
  7. I tried to check off "exlink" gadget's chek box and I went to any JAWP page. Then no error occurs.

It is probable for us to configure not to use exlink gadget and then pages work as we expected.

ねをなふみそね (talkcontribs)

The latest version (5.3 September 27 2016) of mobile firefox for iOS often crashes when reading Japanese Wikipedia pages. I don't know whether this phenomenon relates to the configuration errors in JAWP or not.

Amire80 (talkcontribs)
ねをなふみそね (talkcontribs)

I found another user reported the problem when browsing JAWP with the latest version of firefox on December 10. See ja:Wikipedia‐ノート:ガジェット#Firefox での閲覧について.

This guy says, pages generated by MediaWiki 1.29.0-wmf.5 are able to be read by firefox but the browser doesn't finish reading pages when reading pages in the condition that the check-box of "Open external links in a new tab or window" is turned on in the Preferences.